summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2017-08-16 13:33:04 -0400
committerTed Alff2017-08-16 13:33:04 -0400
commit57d20ee249b35abb79cf71507b44f92a72e15bc6 (patch)
treef1f43b4a910a1c2cfa615d0d93afb46aa2c2cf84 /PKGBUILD
parente3306fb514219a1c0ec4ba8c18bbfbf8aeb51764 (diff)
downloadaur-57d20ee249b35abb79cf71507b44f92a72e15bc6.tar.gz
Removed patch to revert xfconf 4.13 dependency. Now requires xfconf>=4.13.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 6 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aad6ca6a71ac..7777f8031eb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,33 +3,25 @@
_pkgname=xfce4-settings
pkgname=${_pkgname}-devel
pkgver=4.13.1
-pkgrel=1
+pkgrel=2
pkgdesc="Settings manager for xfce"
arch=('i686' 'x86_64')
url="http://www.xfce.org/"
license=('GPL2')
groups=('xfce4')
depends=('exo>=0.11.0' 'garcon' 'libxfce4ui>=4.13' 'libnotify' 'libxklavier'
- 'gnome-icon-theme' 'gtk-engines' 'dbus-glib')
-makedepends=('intltool' 'git' 'xfce4-dev-tools')
+ 'gnome-icon-theme' 'gtk-engines' 'dbus-glib' 'xfconf>4.13.0')
+makedepends=('intltool')
optdepends=('libcanberra: for sound control')
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
-source=(${_pkgname}-$pkgver::git://git.xfce.org/xfce/xfce4-settings#commit=3effeb4908b8d3ed00b11b5fcac27b745500c9f4
- #"http://archive.xfce.org/src/xfce/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2"
- 'xfconf_4.13.patch::https://git.xfce.org/xfce/xfce4-settings/patch/?id=6a5930fb1050f99b6e494eedcca977e74cba7f62')
-
-prepare() {
- cd "$srcdir/$_pkgname-$pkgver"
- # Reverse the patch that requires xfconf > 4.13
- patch -uRp1 -i ../xfconf_4.13.patch
-}
+source=("http://archive.xfce.org/src/xfce/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2")
+sha256sums=('01b9e9df6801564b28f3609afee1628228cc24c0939555f60399e9675d183f7e')
build() {
cd "$srcdir/$_pkgname-$pkgver"
- #./configure
- ./autogen.sh \
+ ./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
@@ -48,6 +40,3 @@ package() {
cd "$srcdir/$_pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
-
-sha256sums=('SKIP' #'01b9e9df6801564b28f3609afee1628228cc24c0939555f60399e9675d183f7e'
- '7229829a88251676308a6fdd8100eae13a1c0228308074f0d8b983efba2a14b3')