summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2020-01-18 14:39:00 -0500
committerTed Alff2020-01-18 14:39:00 -0500
commite9668e6403a616dbe7db20b384b9de4bc0128be3 (patch)
tree2cbbe61a7b9634c1705a14b464fa6e0c410c4bf1 /PKGBUILD
parent205be1ef55f1f9484b2689f48fdee98825b813eb (diff)
downloadaur-e9668e6403a616dbe7db20b384b9de4bc0128be3.tar.gz
Version bump 4.15.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb812b791801..4c54cffa501b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,30 @@
_pkgname=xfce4-settings
pkgname=${_pkgname}-devel
-pkgver=4.13.8
+pkgver=4.15.0
pkgrel=1
pkgdesc="Settings manager for xfce"
arch=('i686' 'x86_64')
url="https://www.xfce.org/"
license=('GPL2')
groups=('xfce4-devel')
-depends=('exo' 'garcon' 'libxfce4ui>=4.13' 'libnotify' 'libxklavier'
- 'gnome-icon-theme' 'gtk-engines' 'xfconf>4.13.0' 'upower' 'colord')
+depends=('exo' 'garcon' 'libxfce4ui>=4.15.1' 'xfconf' 'libnotify' 'colord'
+ 'libxklavier' 'adwaita-icon-theme' 'gnome-themes-extra')
makedepends=('intltool')
optdepends=('libcanberra: for sound control')
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
-source=("https://archive.xfce.org/src/xfce/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2")
-sha256sums=('34ad226860e4cd8c13f6f0dc88e68a37173823c5a4c96ba9bfa89f869df086e7')
+source=("https://archive.xfce.org/src/xfce/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2"
+ 'default-xsettings-xml.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/default-xsettings-xml.patch?h=packages/xfce4-settings')
+sha256sums=('ff3a97ca85943566d2adb6a132bbac913933419b3e95f4595e81c9381f22e816'
+ '8e9a6c70ab0ceb5d91b637dc290768f8a47edb5d7b6e2eebc4459dbc4ee040d7')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ # Enable Adwaita theme and font hinting by default
+ patch -Np1 -i "$srcdir/default-xsettings-xml.patch"
+}
build() {
cd "$srcdir/$_pkgname-$pkgver"