summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCédric Leporcq2015-06-14 19:44:22 +0200
committerCédric Leporcq2015-06-14 19:44:22 +0200
commit821b02cc01cfb678147fb642a0eada570759287b (patch)
tree1d99e150da4550b7ddb1b84d2ae9699db3f3dbd6 /PKGBUILD
downloadaur-821b02cc01cfb678147fb642a0eada570759287b.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7255f3ce9f7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Cedric Leporcq <cedric at gmail dot com>
+
+pkgname=xfce4-windowck-plugin
+pkgver=0.4.2
+pkgrel=1
+pkgdesc="Xfce panel plugin which allows to put the maximized window title and buttons on the panel."
+arch=('i686' 'x86_64')
+url="https://github.com/cedl38/xfce4-windowck-plugin"
+license=('GPL3')
+groups=('xfce4')
+depends=('xfce4-panel')
+makedepends=('intltool' 'xfce4-dev-tools' 'python3' 'imagemagick')
+options=('!libtool')
+install=$pkgname.install
+source=("$pkgname-$pkgver.tar.gz::https://github.com/cedl38/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('23160fb91875187c2d535989207192b4dc3352e20e6f6f6d7135e0fc440dd740')
+
+build() {
+ cd "$srcdir/${pkgname}-$pkgver"
+
+ ./autogen.sh \
+ --prefix=/usr
+
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}-$pkgver"
+ make DESTDIR="$pkgdir" install
+}