summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorViktor Semykin2017-02-16 23:41:29 -0300
committerViktor Semykin2017-02-16 23:42:55 -0300
commitddb5cbe126c6860aeaa2d0c777378aa0c02127ca (patch)
treed1214a2f0f9294c9805ccee5bcafba23c35153db /PKGBUILD
downloadaur-ddb5cbe126c6860aeaa2d0c777378aa0c02127ca.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5f02fc2467d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+#Maintainer: Viktor Semykin <thesame.ml@gmail.com>
+
+pkgname="xfce4-wmdock-plugin"
+pkgver="0.6.0"
+pkgrel=1
+pkgdecs="XFCE4 Panel plugin as a compatibility layer for running WindowMaker dockapps on the XFCE desktop."
+arch=('i686' 'x86_64')
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-wmdock-plugin"
+license=("GPL2")
+depends=("libxfce4ui" "libxfce4util" "libwnck" "xfce4-panel")
+source=("http://archive.xfce.org/src/panel-plugins/xfce4-wmdock-plugin/0.6/xfce4-wmdock-plugin-0.6.0.tar.bz2"
+ "libxfce4ui.patch")
+
+md5sums=("1e82b7561357c4490fc2402290bce52f" "4cf6fdc14935f01e05dbf1126a50501d")
+
+prepare () {
+ cd "$pkgname-$pkgver"
+ patch -p1 -i "$srcdir/libxfce4ui.patch"
+}
+
+build () {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}