summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2017-11-18 12:57:04 -0500
committerTed Alff2017-11-18 12:57:04 -0500
commit0e12505495c21777ea8fc149ba93309e890cb49f (patch)
tree21ad825912bce87b030a5fbc985f070657377d7d /PKGBUILD
parent7bc35a53156e2f83f0232a7c32b371f83e9e1ef6 (diff)
downloadaur-0e12505495c21777ea8fc149ba93309e890cb49f.tar.gz
xfdesktop desktop plugin ported to thunarx-3 not available in released thunar - update deps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a7b1eed9edf..30ab73180b9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
_pkgname=xfdesktop
pkgname=${_pkgname}-git
-pkgver=4.12.0.r306.gd94b562d
+pkgver=4.13.1.r113.g25ae88bd
pkgrel=1
pkgdesc="A desktop manager for Xfce (git version)"
arch=('i686' 'x86_64')
url="http://www.xfce.org/"
license=('GPL2')
groups=('xfce4')
-depends=('libxfce4ui>=4.12.0' 'garcon>=0.5.0' 'hicolor-icon-theme' 'libwnck3' 'thunar')
+depends=('libxfce4ui>=4.13.0' 'garcon>=0.6.0' 'hicolor-icon-theme' 'libwnck3') # 'thunar')
makedepends=('intltool' 'git' 'xfce4-dev-tools')
conflicts=('xfce4-menueditor' "${_pkgname}")
provides=("${_pkgname}=${pkgver%%.r*}")
@@ -18,6 +18,10 @@ options=('!libtool')
source=("${_pkgname}::git://git.xfce.org/xfce/xfdesktop")
sha256sums=('SKIP')
+# Desktop plugin has been ported to thunarx-3. If thunar-git is installed, it will be built so
+# add to dependencies, otherwise add missing dependencies that thunar would otherwise satisfy.
+[[ "$( pacman -Qq thunar-git 2>/dev/null )" != '' ]] && depends+=('thunar-git') || depends+=('exo>=0.11.0' 'libnotify')
+
pkgver() {
cd "${srcdir}/${_pkgname}"
git describe --long --tags | sed -r "s/^${_pkgname}.//;s/([^-]*-g)/r\1/;s/-/./g"
@@ -32,8 +36,6 @@ build() {
--libexecdir=/usr/lib \
--localstatedir=/var \
--disable-static \
- --enable-gio-unix \
- --enable-thunarx \
--enable-notifications \
--disable-debug
make