summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2023-01-11 09:06:24 -0500
committerTed Alff2023-01-11 09:06:24 -0500
commitfa8c76ba86f7059933fbbcc02f118074d74cedfe (patch)
treecc5d68344958959ffdd10cbfdf2d4f1793902df6 /PKGBUILD
parent72507bf3263839c7fc93578da01d6117a8630572 (diff)
downloadaur-fa8c76ba86f7059933fbbcc02f118074d74cedfe.tar.gz
Update to 4.19.x with initial wayland support and dependencies.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 238cc503aa8d..3f2921f23616 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
_pkgname=xfdesktop
pkgname=${_pkgname}-git
-pkgver=4.14.0+150+g044d5dc5
+pkgver=4.19.0+6+ge31efdf0
pkgrel=1
-pkgdesc="A desktop manager for Xfce (git version)"
+pkgdesc="A desktop manager for Xfce (git checkout)"
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
-url="http://www.xfce.org/"
+url="https://docs.xfce.org/xfce/xfdesktop/start"
license=('GPL2')
-groups=('xfce4')
-depends=('libxfce4ui>=4.13.0' 'garcon>=0.6.0' 'hicolor-icon-theme' 'libwnck3' 'thunar')
+groups=('xfce4-git')
+depends=('thunar' 'garcon' 'hicolor-icon-theme' 'libwnck3'
+ 'libxfce4windowing>=4.19.1' 'gtk-layer-shell')
makedepends=('intltool' 'git' 'xfce4-dev-tools')
conflicts=('xfce4-menueditor' "${_pkgname}")
provides=("${_pkgname}=${pkgver%%+*}")
@@ -32,7 +33,9 @@ build() {
--libexecdir=/usr/lib \
--localstatedir=/var \
--disable-static \
+ --enable-thunarx \
--enable-notifications \
+ --enable-wayland \
--disable-debug
make
}