summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortaotieren2021-05-26 14:01:58 +0800
committertaotieren2021-05-26 14:01:58 +0800
commit70fa66018b3493b0196ed793021af9955cfb9b9a (patch)
treed6d2baa9e0d4b3d25c3559d5a3352eb745ab8aeb /PKGBUILD
downloadaur-70fa66018b3493b0196ed793021af9955cfb9b9a.tar.gz
Update xfel-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf7b5af7a8b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=xfel-git
+pkgver=d66fb6a
+pkgrel=1
+pkgdesc="Tiny FEL tools for allwinner SOC, support RISC-V D1 chip."
+arch=('any')
+url="https://github.com/xboot/xfel"
+license=('MIT')
+provides=(${pkgname})
+conflicts=(${pkgname} ${pkgname%-git})
+#replaces=(${pkgname})
+depends=('libusb')
+makedepends=('git')
+backup=()
+options=('!strip')
+#install=${pkgname}.install
+source=("${pkgname%-git}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-git}"
+ make
+}
+
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-git}/${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
+ install -Dm644 "${srcdir}/${pkgname%-git}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
+}