summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames Duley2015-07-12 13:14:19 +0100
committerJames Duley2015-07-12 13:14:19 +0100
commite565de0a9cedb18610bbcb2202d00e5cd2b34e1e (patch)
tree94be9fa07c6a3b6a763eda7915b5edc39912b1f3 /PKGBUILD
downloadaur-e565de0a9cedb18610bbcb2202d00e5cd2b34e1e.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9213f526cc86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Original Contributor: Gareth R <newtackdesign@gmail.com>
+# Contributor: Simon K <simon@booya.at>
+# Maintainer: James Duley <jagduley gmail>
+
+pkgname=xflr5
+pkgver=6.10.04
+pkgrel=1
+pkgdesc="An analysis tool for airfoils, wings and planes operating at low Reynolds Numbers."
+arch=('i686' 'x86_64')
+url="http://xflr5.sourceforge.net/xflr5.htm"
+license=('GPL')
+depends=('qt5-base' 'mesa')
+makedepends=()
+source=("http://download.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}_src.tar.gz")
+md5sums=('1cdbf8c8c941e2387eab74f7f5a27e76')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver%.*}"
+ qmake-qt5
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver%.*}"
+ make INSTALL_ROOT="$pkgdir" install
+}
+