summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMihai Bişog2016-01-31 16:07:48 +0200
committerMihai Bişog2016-01-31 16:07:48 +0200
commitda0c752df6b0dacf409e67afee4fab48971eac7d (patch)
tree19a4e832fdcf28a21df373906f0dbc24ba230491 /PKGBUILD
downloadaur-da0c752df6b0dacf409e67afee4fab48971eac7d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..073baa7aced0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Mihai Bisog <mihai.bisog@gmail.com>
+pkgname=xfstk-dldr
+pkgver=1.8.1
+pkgrel=1
+pkgdesc="Update Intel SoC firmware over USB using the DNX protocol"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/xfstk/"
+license=('LGPL')
+depends=('qt4' 'libusb' 'boost')
+makedepends=('doxygen' 'graphviz' 'cmake')
+provides=('xfstk-dldr' 'xfstk-dldr-gui')
+conflicts=('xfstk-dldr' 'xfstk-dldr-gui')
+source=("http://sourceforge.net/projects/xfstk/files/$pkgname-linux-source-$pkgver.tar.gz")
+md5sums=("c076b3bbbe9907ef2eb7958e17b152bd")
+
+prepare() {
+ cd "xfstk-build/linux-source-package"
+ mkdir -p build
+ cd build
+ BUILD_VERSION=$pkgver cmake .. -DCMAKE_INSTALL_PREFIX:PATH=/usr
+}
+
+build() {
+ cd "xfstk-build/linux-source-package/build"
+ make
+}
+
+package() {
+ cd "xfstk-build/linux-source-package/build"
+ make DESTDIR="$pkgdir/" install
+}