summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortomKPZ2021-06-01 07:14:43 -0700
committertomKPZ2021-06-01 07:14:43 -0700
commitf6b8d7fcc78c687d2691bc21242041d745213ee0 (patch)
tree8a74ee82681cec9eb012800b28dd9eab400d30bb /PKGBUILD
downloadaur-f6b8d7fcc78c687d2691bc21242041d745213ee0.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bfaeae3518c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+_pkgname=xfswm
+pkgname=${_pkgname}-git
+pkgver=r12.0dc53b7
+pkgrel=1
+pkgdesc="An X11 window manager that keeps a single window fullscreen"
+url="https://github.com/tomKPZ/xfswm"
+arch=("x86_64")
+url="https://github.com/tomKPZ/x-active-window-indicator"
+depends=("glibc" "libx11")
+makedepends=("cmake" "git")
+
+source=("git+https://github.com/tomKPZ/xfswm.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make DESTDIR="$pkgdir" install
+}