summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDmitry Popov2020-02-13 23:49:58 +0300
committerDmitry Popov2020-02-14 00:12:08 +0300
commit576edabfbf93502af2af18d025d4d382d82bb3a2 (patch)
treecfbe76bb1f7c24d249c4485859d4985957c90916 /PKGBUILD
parentddb21f864ea7e472ca9dc0e4523d226ed5c01d60 (diff)
downloadaur-576edabfbf93502af2af18d025d4d382d82bb3a2.tar.gz
Bump version (to r4049.911a90283) and fix patches accordingly
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a9f73ae31ad..24faa8b1bef5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _name=xgboost
pkgbase=xgboost-git
pkgname=('xgboost-git'
'python-xgboost-git')
-pkgver=r3854.97007765
+pkgver=r4049.911a90283
pkgrel=1
url='https://github.com/dmlc/xgboost'
license=('APACHE')
@@ -19,7 +19,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'c717e84c937ce3c6bb710f39ddcf0588e61deb0e356836abd0257158703b225e')
+ '4940b84afffe9c2be646d0f77bcfb0d8d36aadcabc4a83b40113e1d97ae917b5')
pkgver() {
cd "${_name}"
@@ -38,6 +38,9 @@ prepare() {
build() {
cd "${_name}"
+ mkdir build
+ cd build
+ cmake .. # -DUSE_CUDA=ON
make
}
@@ -60,7 +63,6 @@ package_xgboost-git() {
# Install shared libraries
mkdir -p "${pkgdir}/usr/lib"
- install -Dm644 lib/*.a "${pkgdir}/usr/lib"
install -Dm644 lib/*.so "${pkgdir}/usr/lib"
# Install includes