summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-11-13 06:32:36 +1300
committercaltlgin2020-11-13 06:32:36 +1300
commitf2a9005b5f389fbde464273eb22461838fb9fdf4 (patch)
tree3888191e12938817b41072d2501270f66b57bee3 /PKGBUILD
downloadaur-f2a9005b5f389fbde464273eb22461838fb9fdf4.tar.gz
Add to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e76f1172fd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='xidel'
+pkgname="${_pkgname}-bin"
+pkgver=0.9.8
+pkgrel=1
+pkgdesc='Command line tool to process HTML/XML/JSON locally or from online sources'
+arch=('x86_64')
+url='http://videlibri.sourceforge.net/xidel.html'
+_url_source='https://sourceforge.net/projects/videlibri'
+license=('GPL3')
+optdepends=('openssl: https connections')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}-${pkgver}.deb::${_url_source}/files/${_pkgname^}/${_pkgname^} ${pkgver}/${_pkgname}_${pkgver}-1_amd64.deb/download")
+sha256sums=('f6a6e29b77547d5ae38383440bd653b3eaf9eeb470def14cc48154a4f6925f69')
+
+package() {
+ tar -xvf 'data.tar.xz' -C "${pkgdir}"
+ rm -rf "${pkgdir}/usr/share/"{'doc','lintian'}
+}
+
+# vim: ts=2 sw=2 et: