summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Shalygin2016-02-11 09:59:26 +0600
committerKonstantin Shalygin2016-02-11 09:59:26 +0600
commitc55d48b872a29aa206c893d7fe83affd7d2cb469 (patch)
tree2aaf9099860e10414e7f693d737660a77f6b2aee /PKGBUILD
parent5d0bc02d92942b461113916eb74a7991d66dee75 (diff)
downloadaur-xidle.tar.gz
bump to 26052015
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 18 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03e938951d10..610341cbb11d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,26 @@
-# Maintainer: MichaƂ Kazior <kazikcz at gmail dot com>
-pkgname=xidle
-pkgver=24102005
-pkgrel=1
-epoch=
+# Maintainer: Konstantin Shalygin <k0ste@cn.ru>
+
+pkgname='xidle'
+pkgver='26052015'
+pkgrel='1'
pkgdesc="xidle runs a program on X inactivity"
-arch=(i686 x86_64)
-url="http://www.freshports.org/x11/xidle"
+arch=('any')
+url="http://www.freshports.org/x11/${pkgname}"
license=('BSD')
-groups=()
-depends=(libxss libxext libx11)
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=(Makefile LICENSE http://distcache.freebsd.org/local-distfiles/novel/$pkgname-$pkgver.tar.bz2)
-noextract=()
-
+depends=('libxss' 'libxext' 'libx11')
+source=("Makefile"
+ "http://distcache.freebsd.org/local-distfiles/novel/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('157242d569537ae00b2ddc57b3b7abdbb551b5294adfaefb7bd02f00ee6c3cc8'
+ 'a7ba1b887c0f4d9d080dc7f49569bf48e3df1d9f2c08b11cffd159c5a15b174c')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- make -f ../Makefile
-}
-
-check() {
- return 0
+ pushd "${pkgname}-${pkgver}"
+ make -f ../Makefile
+ popd
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make -f ../Makefile DESTDIR="$pkgdir/" install
- install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ pushd "${pkgname}-${pkgver}"
+ make -f ../Makefile DESTDIR="${pkgdir}" install
+ popd
}
-
-md5sums=('acfd0e9b0f8e9d123edd9f7575696981'
- 'fc5e113e43e90e9b23299ee186aca0c8'
- '6d4067b5adac594aa5917f2265cc02ee')