summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBermond2016-02-27 14:31:33 -0300
committerBermond2016-02-27 14:31:33 -0300
commit35975b62a643c85b9c6ddcfbee4584945aadd13e (patch)
tree410aa2069825990e0aeee03a865f907d36c8c074 /PKGBUILD
parentcbd02a593b2ed27cfdad0c41f3d07afe522e82bf (diff)
downloadaur-35975b62a643c85b9c6ddcfbee4584945aadd13e.tar.gz
Added tab spaces
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD144
1 files changed, 71 insertions, 73 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7015aa8a0be..559d1180cf19 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=xine-lib-hg
pkgver=r12705.1f688d8f0cb3
-pkgrel=1
+pkgrel=2
pkgdesc="A multimedia playback engine (Mercurial version with all possible libs)"
arch=('i686' 'x86_64')
url="https://www.xine-project.org/"
@@ -26,11 +26,9 @@ sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname}"
-
- # Mercurial
+ # Mercurial
printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
-
}
prepare() {
@@ -42,75 +40,75 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}"
- ./configure \
- --prefix=/usr \
- \
- --enable-static=no \
- --enable-shared=yes \
- --enable-fast-install=yes \
- \
- --enable-oss \
- --enable-aalib \
- --disable-dha-kmod \
- --enable-directfb \
- --enable-dxr3 \
- --enable-fb \
- --enable-opengl \
- --enable-glu \
- --disable-vidix \
- --enable-xinerama \
- --enable-xvmc \
- --enable-vdpau \
- --enable-vaapi \
- --enable-dvb \
- --enable-gnomevfs \
- --enable-samba \
- --enable-v4l2 \
- --enable-libv4l \
- --enable-vcd \
- --enable-vdr \
- --enable-bluray \
- --enable-avformat \
- --enable-a52dec \
- --enable-asf \
- --enable-nosefart \
- --enable-faad \
- --enable-gdkpixbuf \
- --enable-libjpeg \
- --enable-dts \
- --enable-mad \
- --enable-modplug \
- --enable-libmpeg2new \
- --enable-musepack \
- --enable-mng \
- --enable-vpx \
- \
- --with-freetype \
- --with-fontconfig \
- --with-x \
- --with-alsa \
- --with-esound \
- --without-fusionsound \
- --with-jack \
- --with-pulseaudio \
- --with-caca \
- --without-linux-path \
- --without-libstk \
- --with-sdl \
- --with-xcb \
- --with-imagemagick \
- --with-libflac \
- --with-speex \
- --with-theora \
- --with-vorbis \
- --with-wavpack
-
- # TODO:
- # --enable-dha-kmod
- # --enable-vidix
- # --with-fusionsound
- # --with-linux-path=/usr/lib/modules/$(uname -r)/build
- # --with-libstk
+ ./configure \
+ --prefix=/usr \
+ \
+ --enable-static=no \
+ --enable-shared=yes \
+ --enable-fast-install=yes \
+ \
+ --enable-oss \
+ --enable-aalib \
+ --disable-dha-kmod \
+ --enable-directfb \
+ --enable-dxr3 \
+ --enable-fb \
+ --enable-opengl \
+ --enable-glu \
+ --disable-vidix \
+ --enable-xinerama \
+ --enable-xvmc \
+ --enable-vdpau \
+ --enable-vaapi \
+ --enable-dvb \
+ --enable-gnomevfs \
+ --enable-samba \
+ --enable-v4l2 \
+ --enable-libv4l \
+ --enable-vcd \
+ --enable-vdr \
+ --enable-bluray \
+ --enable-avformat \
+ --enable-a52dec \
+ --enable-asf \
+ --enable-nosefart \
+ --enable-faad \
+ --enable-gdkpixbuf \
+ --enable-libjpeg \
+ --enable-dts \
+ --enable-mad \
+ --enable-modplug \
+ --enable-libmpeg2new \
+ --enable-musepack \
+ --enable-mng \
+ --enable-vpx \
+ \
+ --with-freetype \
+ --with-fontconfig \
+ --with-x \
+ --with-alsa \
+ --with-esound \
+ --without-fusionsound \
+ --with-jack \
+ --with-pulseaudio \
+ --with-caca \
+ --without-linux-path \
+ --without-libstk \
+ --with-sdl \
+ --with-xcb \
+ --with-imagemagick \
+ --with-libflac \
+ --with-speex \
+ --with-theora \
+ --with-vorbis \
+ --with-wavpack
+
+ # TODO:
+ # --enable-dha-kmod
+ # --enable-vidix
+ # --with-fusionsound
+ # --with-linux-path=/usr/lib/modules/$(uname -r)/build
+ # --with-libstk
make
}