summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-02-19 22:53:07 -0300
committerDaniel Bermond2017-02-19 22:53:07 -0300
commit5ff30a61ed079517554cc27c5de2da8653c84538 (patch)
tree5905f1f40e2b65e46085691e9510731af79f9799 /PKGBUILD
parent4767ddcfd2dcde5b486e9133d24157e67e00c4f2 (diff)
downloadaur-5ff30a61ed079517554cc27c5de2da8653c84538.tar.gz
Updated depends, makedepends and optdepends. Added some options.
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD97
1 files changed, 77 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b7e6bb1851e..697e37858af3 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,64 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
-# AUR dependencies: esound
+# AUR dependencies: esound gnome-vfs-nosmb sndio
+
+# NOTE:
+# '--with-imagemagick' works only with ImageMagick 6 and will not work with IM7
+# (and IM git version). If you have IM7 installed, please change it to
+# '--without-magick'.
pkgname=xine-lib-hg
-pkgver=1.2.6.r12710.24fc93301077
+pkgver=1.2.7.r12910.d24c69278026
pkgrel=1
pkgdesc="A multimedia playback engine (Mercurial version with all possible libs)"
arch=('i686' 'x86_64')
url="https://www.xine-project.org/"
-license=('GPL2' 'LGPL')
-depends=(
- 'aalib' 'directfb' 'mesa' 'glu' 'libxinerama' 'libxvmc' 'libvdpau'
- 'linuxtv-dvb-apps' 'gnome-vfs' 'smbclient' 'v4l-utils' 'vcdimager' 'libbluray'
- 'ffmpeg' 'a52dec' 'faad2' 'gdk-pixbuf2' 'libjpeg-turbo' 'libdca' 'libmad'
- 'libmodplug' 'libmpeg2' 'libmpcdec' 'libmng' 'libvpx' 'freetype2' 'fontconfig'
- 'xorg-server-devel' 'alsa-lib' 'esound' 'jack' 'pulseaudio' 'libcaca' 'sdl'
- 'libxcb' 'flac' 'speex' 'libtheora' 'libvorbis' 'wavpack' 'libxv'
+license=('GPL2' 'LGPL2.1')
+depends=('fontconfig')
+makedepends=('mercurial' 'a52dec' 'aalib' 'directfb' 'esound' 'faad2' 'ffmpeg'
+ 'gdk-pixbuf2' 'glu' 'gnome-vfs-nosmb' 'imagemagick<7.0.0.0' 'jack'
+ 'libcaca' 'libcdio' 'libbluray' 'libdca' 'libdvdnav' 'libmad'
+ 'libmng' 'libmpcdec' 'libpulse' 'libvdpau' 'libxinerama' 'libxvmc'
+ 'smbclient' 'v4l-utils' 'vcdimager' 'wavpack'
+)
+optdepends=('a52dec: for using the a52 plugin'
+ 'aalib: for using the aalib plugin'
+ 'alsa-lib: for using the alsa plugin'
+ 'esound: for using the esound plugin'
+ 'faad2: for using the faad plugin'
+ 'ffmpeg: for using the ff/avformat/avutil plugin'
+ 'flac: for using the flac plugin'
+ 'gdk-pixbuf2: for using the gdk-pixbuf plugin'
+ 'glu: for using the opengl plugin'
+ 'gnome-vfs-nosmb: for using the gnome-vfs plugin'
+ 'imagemagick: for using the imagemagick plugin'
+ 'jack: for using the jack plugin'
+ 'libbluray: for using the bluray plugin'
+ 'libcaca: for using the caca plugin'
+ 'libcdio: for using the cd plugin'
+ 'libdca: for using the dts plugin'
+ 'libdvdnav: for using the dvd plugin'
+ 'libjpeg-turbo: for using the libjpeg plugin'
+ 'libmad: for using the mp3 plugin'
+ 'libmng: for using the mng plugin'
+ 'libmodplug: for using the modplug plugin'
+ 'libmpcdec: for using the musepack plugin'
+ 'libpulse: for using the pulseaudio plugin'
+ 'libtheora: for using the xiph plugin'
+ 'libva: for using the vaapi plugin'
+ 'libvdpau: for using the vdpau plugin'
+ 'libvorbis: for using the xiph plugin'
+ 'libvpx: for using the libvpx plugin'
+ 'libxcb: for using the xcb-shm and xcb-xv plugins'
+ 'libxinerama: for using the xv plugin'
+ 'sdl: for using the sdl plugin'
+ 'smbclient: for using the samba plugin'
+ 'sndio: for using the sndio plugin'
+ 'speex: for using the xiph plugin'
+ 'v4l-utils: for using the v4l2 plugin'
+ 'vcdimager: for using the vcd plugin'
+ 'wavpack: for using the wavpack plugin'
)
-makedepends=('mercurial')
provides=('xine-lib')
conflicts=('xine-lib')
source=("$pkgname"::'hg+http://hg.debian.org/hg/xine-lib/xine-lib-1.2-vdpau')
@@ -40,23 +81,34 @@ build() {
./configure \
--prefix=/usr \
\
+ --enable-ipv6 \
+ --enable-antialiasing \
--enable-static=no \
--enable-shared=yes \
--enable-fast-install=yes \
+ --enable-optimizations \
+ --enable-largefile \
+ --enable-libxine-builtins \
\
+ --disable-coreaudio \
+ --disable-irixal \
--enable-oss \
+ --disable-sunaudio \
+ --enable-sndio \
--enable-aalib \
--disable-dha-kmod \
--enable-directfb \
--enable-dxr3 \
--enable-fb \
+ --disable-macosx-video \
--enable-opengl \
--enable-glu \
--disable-vidix \
--enable-xinerama \
+ --disable-static-xv \
--enable-xvmc \
--enable-vdpau \
- --disable-vaapi \
+ --enable-vaapi \
--enable-dvb \
--enable-gnomevfs \
--enable-samba \
@@ -70,15 +122,22 @@ build() {
--enable-asf \
--enable-nosefart \
--enable-faad \
+ --enable-ffmpeg \
+ --enable-postproc \
--enable-gdkpixbuf \
--enable-libjpeg \
--enable-dts \
--enable-mad \
--enable-modplug \
- --enable-libmpeg2new \
+ --disable-libmpeg2new \
--enable-musepack \
+ --disable-mlib \
+ --disable-mlib-lazyload \
--enable-mng \
+ --enable-real-codecs \
+ --disable-w32dll \
--enable-vpx \
+ --disable-mmal \
\
--with-freetype \
--with-fontconfig \
@@ -92,17 +151,14 @@ build() {
--without-linux-path \
--without-libstk \
--with-sdl \
- --without-xcb \
- --without-imagemagick \
+ --with-xcb \
+ --with-external-dvdnav \
+ --with-imagemagick \
--with-libflac \
--with-speex \
--with-theora \
--with-vorbis \
- --with-wavpack
-
- # NOTE:
- # (1): "--enable-vaapi" and "--with-xcb" doesn't work. Disabled
- # (2): "--with-imagemagick" doesn't work with ImageMagick 7 (and imagemagick git). Disabled.
+ --with-wavpack
# TODO:
# --enable-dha-kmod
@@ -110,6 +166,7 @@ build() {
# --with-fusionsound
# --with-linux-path=/usr/lib/modules/$(uname -r)/build
# --with-libstk
+ # --with-openhevc
make
}