summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBermond2016-07-01 15:16:24 -0300
committerBermond2016-07-01 15:16:24 -0300
commitb3a023a1e34f791e0057a68d7ce78ec5cf8b224e (patch)
treea6c15ceae8fbeab68295e95ca21a747e06fab342 /PKGBUILD
parent8a1f5b7a52f87aa8f173fec9dd010b22998bca68 (diff)
downloadaur-b3a023a1e34f791e0057a68d7ce78ec5cf8b224e.tar.gz
Removed options that don't work anymore (xcb and imagemagick)
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e424ba77bbce..66c81c6a4046 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=xine-lib-hg
pkgver=r12707.b748a9de57de
-pkgrel=2
+pkgrel=3
pkgdesc="A multimedia playback engine (Mercurial version with all possible libs)"
arch=('i686' 'x86_64')
url="https://www.xine-project.org/"
@@ -15,8 +15,7 @@ depends=(
'ffmpeg' 'a52dec' 'faad2' 'gdk-pixbuf2' 'libjpeg-turbo' 'libdca' 'libmad'
'libmodplug' 'libmpeg2' 'libmpcdec' 'libmng' 'libvpx' 'freetype2' 'fontconfig'
'xorg-server-devel' 'alsa-lib' 'esound' 'jack' 'pulseaudio' 'libcaca' 'sdl'
- 'libxcb' 'xcb-util-image' 'imagemagick' 'flac' 'speex' 'libtheora' 'libvorbis'
- 'wavpack' 'libxv'
+ 'libxcb' 'flac' 'speex' 'libtheora' 'libvorbis' 'wavpack' 'libxv'
)
makedepends=('mercurial')
provides=('xine-lib')
@@ -91,23 +90,24 @@ build() {
--without-linux-path \
--without-libstk \
--with-sdl \
- --with-xcb \
- --with-imagemagick \
+ --without-xcb \
+ --without-imagemagick \
--with-libflac \
--with-speex \
--with-theora \
--with-vorbis \
--with-wavpack
+ # NOTE:
+ # (1): "--enable-vaapi" and "--with-xcb" doesn't work. Disabled
+ # (2): "--with-imagemagick" doesn't work with ImageMagick 7 (and imagemagick git). Disabled.
+
# TODO:
# --enable-dha-kmod
# --enable-vidix
# --with-fusionsound
# --with-linux-path=/usr/lib/modules/$(uname -r)/build
# --with-libstk
-
- # NOTE:
- # --enable-vaapi doesn't work
make
}