summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Post2022-04-19 02:13:07 +0200
committerVincent Post2022-04-19 02:13:07 +0200
commit177d7404929e772b0a77c35c9659291676d65c6c (patch)
tree7ac6e2ebe93b4068fbf8cbe20067f70ba2d0d309 /PKGBUILD
downloadaur-177d7404929e772b0a77c35c9659291676d65c6c.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..742bd70d3c13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Vincent Post <cent@spline.de>
+pkgname=xivlauncher
+pkgver=6.2.31
+pkgrel=1
+pkgdesc="Custom Launcher for Final Fantasy XIV Online (Crossplatform rewrite)"
+arch=('x86_64')
+url='https://github.com/goatcorp/FFXIVQuickLauncher/'
+license=('GPL')
+depends=('aria2')
+makedepends=('dotnet-sdk')
+optdepends=('steam')
+source=("FFXIVQuickLauncher::git+https://github.com/goatcorp/FFXIVQuickLauncher.git#tag=${pkgver}")
+sha512sums=('SKIP')
+
+build() {
+ mkdir "${srcdir}/build"
+ cd "${srcdir}/FFXIVQuickLauncher/src/XIVLauncher.Core/"
+ dotnet publish -r linux-x64 --sc -o "${srcdir}/build"
+}
+
+package() {
+ mkdir -p "${pkgdir}/opt/XIVLauncher" "${pkgdir}/usr/bin"
+ cp -r "${srcdir}/build/." "${pkgdir}/opt/XIVLauncher/"
+ ln -s ../../opt/XIVLauncher/XIVLauncher.Core "${pkgdir}/usr/bin/XIVLauncher.Core"
+}