summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Post2022-04-19 12:33:18 +0200
committerVincent Post2022-04-19 12:33:18 +0200
commitc1201821c708def71bf0c55712155ca2a042d2c3 (patch)
tree5b99677e48ea74de47a9afb8db7861c9bbf8169b /PKGBUILD
parenteb402b5646e8be0af2dbee524491700207e501f2 (diff)
downloadaur-c1201821c708def71bf0c55712155ca2a042d2c3.tar.gz
now without git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11b0a43c5f93..d35f52a8114c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vincent Post <cent@spline.de>
pkgname=xivlauncher
pkgver=6.2.31
-pkgrel=3
+pkgrel=4
pkgdesc="Custom Launcher for Final Fantasy XIV Online (Crossplatform rewrite)"
arch=('x86_64')
url='https://github.com/goatcorp/FFXIVQuickLauncher/'
@@ -14,19 +14,19 @@ depends=(
makedepends=('dotnet-sdk>=6')
optdepends=('steam')
source=(
- "FFXIVQuickLauncher::git+https://github.com/goatcorp/FFXIVQuickLauncher.git#tag=${pkgver}"
+ "https://github.com/goatcorp/FFXIVQuickLauncher/archive/refs/tags/6.2.31.tar.gz"
"https://raw.githubusercontent.com/goatcorp/FFXIVQuickLauncher/master/src/XIVLauncher.Core/Resources/logo.png"
"XIVLauncher.desktop"
)
sha512sums=(
- 'SKIP'
+ '0f2de5ff1d52e5ed5c799180506d570a01f1d4967106c83e6cebf60493db37e432cb6fcbdfb4f3a067301b0f82ba1919ea23e0412347e4353141dc3795f7f280'
'4f16ba269ecd60c16a125db5e986d0bdabd69ac51d03ccb01a7203ddd04dea9d40147ee412bbfc37921ca83ff70a966258ae729bcada95ce1582b43160686694'
'5ac774f858d4015c59e6758e2a706b93e822bca9c046ed87210deabc141ac101020d2654fbcf8314f9409a4cfcf921d1e26ec0a3b0beab02d1bcd045fb6e6f14'
)
build() {
mkdir "${srcdir}/build"
- cd "${srcdir}/FFXIVQuickLauncher/src/XIVLauncher.Core/"
+ cd "${srcdir}/FFXIVQuickLauncher-${pkgver}/src/XIVLauncher.Core/"
dotnet publish -r linux-x64 --sc -o "${srcdir}/build" --configuration Release
}