summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPerttu Luukko2016-10-19 21:19:08 +0200
committerPerttu Luukko2016-10-19 21:19:08 +0200
commit022cddafca9c3b424ce180e6dfacfce4bb2717c9 (patch)
tree3824363abea42eeb8d92d41df855549f36044f81 /PKGBUILD
parent41b444e9d6c9f869c128ea4d2b66c80fa1fe5e6a (diff)
downloadaur-022cddafca9c3b424ce180e6dfacfce4bb2717c9.tar.gz
Fix check() and add wordlists to optdepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d3e72640380..231a8e9041bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,16 @@
pkgname=xkcdpass
_pkgname=XKCD-password-generator-xkcdpass
pkgver=1.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Generate secure multiword passwords/passphrases, inspired by XKCD"
arch=('any')
url="https://github.com/redacted/XKCD-password-generator"
license=('BSD')
depends=('python')
makedepends=('python-setuptools')
+checkdepends=('python-nose')
+optdepends=('cracklib: alternative wordlist'
+ 'words: alternative wordlist')
options=(!emptydirs)
source=("https://github.com/redacted/XKCD-password-generator/archive/${pkgname}-${pkgver}.tar.gz")
sha256sums=('2e28aa1472a8d86db86e0f49d79309d6d0930229b560c876dc22ee57b2516d02')
@@ -21,7 +24,7 @@ build() {
check() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- python tests/xkcdp_tests.py
+ nosetests tests
}
package() {