summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarco Kundt2015-06-08 23:21:03 +0200
committerMarco Kundt2015-06-08 23:21:03 +0200
commit7a5ac7e591047a7ea42ec419c65c7e5dd98ac0ee (patch)
tree66e23806d930c3bdbf6de889406398d903c7ee97 /PKGBUILD
downloadaur-7a5ac7e591047a7ea42ec419c65c7e5dd98ac0ee.tar.gz
inital commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f80e5ef26dac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Marco Kundt <mrckndt@gmail.com>
+
+pkgname=xkcdpass
+_pkgname=XKCD-password-generator-xkcdpass
+pkgver=1.2.5
+pkgrel=1
+pkgdesc="Generate secure multiword passwords/passphrases, inspired by XKCD"
+arch=('any')
+url="https://github.com/redacted/XKCD-password-generator"
+license=('BSD')
+depends=('python' 'python-setuptools')
+makedepends=()
+options=(!emptydirs)
+source=("https://github.com/redacted/XKCD-password-generator/archive/$pkgname-$pkgver.tar.gz")
+md5sums=('09a01e430099fc853ef910398f4558be')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}