summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Courtis2018-03-31 22:32:52 +1100
committerAlexander Courtis2018-03-31 22:32:52 +1100
commit03cda9d2ca9d6d013947f0d5f37ed71d117c85bf (patch)
tree8e51e4da16cbd8033fadfe415241858d2f32baba /PKGBUILD
downloadaur-03cda9d2ca9d6d013947f0d5f37ed71d117c85bf.tar.gz
initial release 1.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66eb70155b95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Alexander Courtis <alex@courtis.org>
+pkgname=xlayoutdisplay
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Detects and arranges linux display outputs, using XRandR for detection and xrandr for arrangement."
+arch=('x86_64')
+url="https://github.com/alex-courtis/xlayoutdisplay"
+license=('Apache')
+depends=('xorg-xrandr' 'xorg-xrdb' 'libxcursor' 'boost')
+makedepends=('git' 'cmake')
+source=("https://github.com/alex-courtis/xlayoutdisplay/archive/v$pkgver.tar.gz")
+sha256sums=('09cad0583bb8e8287cfcd2ca386be5908ca7a1a2')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make install
+}