summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathan Liu2015-06-19 11:52:45 +1000
committerJonathan Liu2015-06-19 11:52:45 +1000
commit1f284a4dbd69e5d919258365aa59efd57efa7ceb (patch)
treeee84c0438ab263b6056acd36eef756719884f5ea /PKGBUILD
downloadaur-1f284a4dbd69e5d919258365aa59efd57efa7ceb.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2b35b330e98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Jonathan Liu <net147@gmail.com>
+pkgname=xmbmon
+pkgver=2.05
+pkgrel=4
+pkgdesc="X Motherboard Monitor"
+arch=('i686' 'x86_64')
+url="http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/download.html"
+license=('GPL')
+depends=('libxt')
+source=("http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/xmbmon/xmbmon205.tar.gz"
+ "Makefile.in.patch"
+ "font.patch")
+md5sums=('ab6614c785f5b653fcc69fb9c02058f0'
+ '3f0659309f48935ce511d9ff87e76d65'
+ '19d78a98841fe1c3705ea788e422592f')
+
+build() {
+ cd "${srcdir}/${pkgname}${pkgver//\./}"
+ patch -Np1 -i "${srcdir}/Makefile.in.patch"
+ patch -Np0 -i "${srcdir}/font.patch"
+ ./configure --build=i686-pc-linux-gnu
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}${pkgver//\./}"
+ install -d -m755 "${pkgdir}/usr"/{bin,share/man/man1}
+ make DESTDIR="${pkgdir}" install install-man
+}
+
+# vim:set ts=2 sw=2 et: