summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSanpi2016-01-12 21:45:31 +0100
committerSanpi2016-01-12 21:52:28 +0100
commit8b0cedf3c84e9d9acbd55dc3a9f30365df4394bf (patch)
treeff562af67920047eb957e90ba55febdf5a95668a /PKGBUILD
downloadaur-xmind2latex.tar.gz
Inital import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a226d2c485c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Sanpi <sanpi+aur@homecomputing.fr>
+pkgname=xmind2latex
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='Tool that reads a XMind mind map and derives a structured latex document.'
+arch=('x86_64')
+url="https://github.com/arnehaber/$pkgname"
+license=('Apache')
+depends=('sh' 'java-environment')
+makedepends=()
+source=("https://github.com/arnehaber/$pkgname/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.zip")
+sha256sums=('9bc5e8562aeebbd2201718e4f555309f34661f09ff2c06608dce73794856cd80')
+
+package() {
+ mkdir -p $pkgdir/usr/{bin,lib}
+
+ cp -r "$srcdir/bin" "$srcdir/repo" "$pkgdir/usr/lib"
+ rm "$pkgdir/usr/lib/bin/xmind2latex.bat"
+
+ cd "$pkgdir/usr/bin"
+ ln -s "../lib/bin/xmind2latex"
+}