summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRod Kay2022-05-12 20:18:40 +1000
committerRod Kay2022-05-12 20:18:40 +1000
commit87586e0bf3d1a07f4d968891e3a689052de40363 (patch)
treef1e84a1bffe4250a9d0372283ef7a4ad9df8c07b /PKGBUILD
parenta47deaec1d2edb8711ee7fef87d00405d60e78b1 (diff)
downloadaur-87586e0bf3d1a07f4d968891e3a689052de40363.tar.gz
Rid '-Werror=format-security' and '-Wformat' from CFLAGS.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a5aee756b5dc..fd5c6af1fe21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,6 +32,10 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr --libexecdir=/lib --enable-shared
+ # Rid flags not used by Ada.
+ CFLAGS="${CFLAGS//-Wformat}"
+ CFLAGS="${CFLAGS//-Werror=format-security}"
+
# Make using a single job (-j1) to avoid the same file being compiled at the same time.
make -j1 GPRBUILD_OPTIONS=-R
}