summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZejun Wu2015-10-03 19:11:05 -0700
committerZejun Wu2015-10-03 19:31:22 -0700
commit26208e24995df0c16c86be809cb4c81174906568 (patch)
tree137733931667715a8ada7a75fa38db455776dc27 /PKGBUILD
downloadaur-26208e24995df0c16c86be809cb4c81174906568.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c31bb24f3618
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: kfgz <kfgz at interia pl>
+# Contributor: watashi <zejun dot wu at gmail dot com>
+
+pkgname=xmount
+pkgver=0.7.3
+pkgrel=1
+pkgdesc="Tool to crossmount between multiple input and output harddisk image files"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="https://www.pinguin.lu"
+depends=('fuse' 'libewf' 'afflib')
+options=(!makeflags)
+source=(http://files.pinguin.lu/${pkgname}-${pkgver}.tar.gz)
+sha256sums=('ab2240f79ebfa2119452d8f5327dbc5b7a4d043747d36d897b8f5a207dab9888')
+
+build() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ #autoreconf -f
+ #LIBS='-lz' ./configure --prefix=/usr
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ make
+}
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}/build
+ make DESTDIR="${pkgdir}" install
+}