summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin Brodsky2020-01-26 00:08:46 +0000
committerKevin Brodsky2020-01-26 00:08:46 +0000
commitc61703b73d312b226c8a57f3c22a620416d2683c (patch)
tree0fa1856dbbff60661ea830a08df3181e3fcaa094 /PKGBUILD
parent52679d64cad93828e42a7c8f8b8c558f943ee1a1 (diff)
downloadaur-c61703b73d312b226c8a57f3c22a620416d2683c.tar.gz
upgpkg: 0.95
libfreetype is now shipped in the archive, but we need to remove it because it is not compatible with the system libfontconfig. Additionally, the shipped platformthemes libs don't seem to have been updated for the new Qt libs (5.12.6), so setting QT_QPA_PLATFORMTHEME triggers: Cannot mix incompatible Qt library (version 0x50907) with this library (version 0x50c06) Not much can be done about this, short of using the system Qt libs (which is what my xnviewmp-system-libs package does).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c93278886eb8..7afce4bb95f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Contributor: Martin Poljak <martin 'at' poljak 'dot' cz>
pkgname=xnviewmp
-pkgver=0.94.3
+pkgver=0.95
srcrel=1 # Incremented when there is a new release for the same version number
pkgrel=1
pkgdesc="An efficient multimedia viewer, browser and converter."
@@ -21,7 +21,7 @@ optdepends=('glib2: support for moving files to trash')
source=("XnViewMP-linux-x64_${pkgver}-rel${srcrel}.tgz::http://download.xnview.com/XnViewMP-linux-x64.tgz"
'xnviewmp.desktop')
-md5sums=('9380ae82adbe422dd181b8b9bb63a884'
+md5sums=('78d546aefb66a9b6b11b1d966b9e9ba3'
'24f44d5a881b94daf48775213a57e4ec')
package() {
@@ -39,6 +39,12 @@ package() {
rm "${pkgdir}/opt/${pkgname}/XnView.desktop"
chmod 644 "${pkgdir}/opt/${pkgname}"/xnview*.png
chmod 755 "${pkgdir}/opt/${pkgname}/XnView"
+
+ # Some old version of libfreetype started getting shipped in 0.95.
+ # libfreetype depends on libfontconfig, but since libfontconfig is not
+ # provided in the archive and the system one is not compatible, we need to
+ # remove it so that the XnView uses the system libfreetype.
+ rm "${pkgdir}/opt/${pkgname}/lib/libfreetype.so"*
}
# vim:set ts=2 sw=2 et: