summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin Brodsky2017-01-24 22:08:10 +0000
committerKevin Brodsky2017-01-25 00:54:36 +0000
commit83190757ccdb8c6eb543bae18d5c0a00b55faf12 (patch)
treef3b2abdfc23f07a5144abea002f43d3215ecb024 /PKGBUILD
parent23df8d23ae97eeb5c7ee8cdd74add1f9363f5b22 (diff)
downloadaur-83190757ccdb8c6eb543bae18d5c0a00b55faf12.tar.gz
Version source archives
Add the version number to the downloaded source archives. This talks makepkg into redownloading the sources when there is a new release, instead of keeping the old archive and failing the checksum. This also has the nice side-effect of keeping previous source versions, should one want to downgrade the package. Since upstream does not always bump the version number when releasing new sources, I had to use a trick to make it work. "-rel$srcrel" is appended to the filename, and if new sources of the same version are released, srcrel is incremented (and then reset to 1 when a new version is released). Not beautiful, but it should do the job.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7815c1c6287..fe7eb36446fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,6 +3,7 @@
pkgname=xnviewmp-system-libs
_pkgname=xnviewmp
pkgver=0.84
+srcrel=1 # Incremented when there is a new release for the same version number
pkgrel=1
pkgdesc="An efficient multimedia viewer, browser and converter (using system libraries)."
url="http://www.xnview.com/en/xnviewmp/"
@@ -14,8 +15,8 @@ optdepends=('gvfs: support for moving files to trash')
conflicts=('xnviewmp')
source=('xnviewmp.desktop')
-source_x86_64=('http://download.xnview.com/XnViewMP-linux-x64.tgz')
-source_i686=('http://download.xnview.com/XnViewMP-linux.tgz')
+source_x86_64=("XnViewMP-linux-x64_${pkgver}-rel${srcrel}.tgz::http://download.xnview.com/XnViewMP-linux-x64.tgz")
+source_i686=("XnViewMP-linux_${pkgver}-rel${srcrel}.tgz::http://download.xnview.com/XnViewMP-linux.tgz")
md5sums=('24f44d5a881b94daf48775213a57e4ec')
md5sums_x86_64=('a1202367f23f32e14a6a0d860564e1da')
md5sums_i686=('75e9e03aa41da988eb66524574794b31')