summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Grande2021-02-07 14:49:38 -0500
committerVincent Grande2021-02-07 14:49:38 -0500
commitd7952426189bf24e7d7d4efdc91d3782e5694927 (patch)
tree0274f9d7487407fb930055559831d0c759e8c55a /PKGBUILD
parentfa70bb26e77f5e9a87a369f48f5f6d7f38cbc58b (diff)
downloadaur-d7952426189bf24e7d7d4efdc91d3782e5694927.tar.gz
disable xwayland, pure x11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4dcaf3b5e320..08d65df97a81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=(
# 'xorg-server-xephyr-rootless-nosystemd-minimal-git'
# 'xorg-server-xvfb-rootless-nosystemd-minimal-git'
# 'xorg-server-xnest-rootless-nosystemd-minimal-git'
- 'xorg-server-xwayland-rootless-nosystemd-minimal-git'
+# 'xorg-server-xwayland-rootless-nosystemd-minimal-git'
'xorg-server-common-rootless-nosystemd-minimal-git'
'xorg-server-devel-rootless-nosystemd-minimal-git')
@@ -71,7 +71,7 @@ build() {
-D ipv6=false \
-D xcsecurity=true \
-D xorg=true \
- -D xwayland=true \
+ -D xwayland=false \
-D xwayland_eglstream=false \
-D udev=true \
-D suid_wrapper=false \
@@ -83,7 +83,7 @@ build() {
-D xinerama=true \
-D screensaver=false \
-D dmx=false \
- -D glamor=true \
+ -D glamor=false \
-D linux_apm=false \
-D mitshm=true \
-D vgahw=false \
@@ -127,10 +127,11 @@ build() {
# mitshm required for nvidia blob/amdgpu/mesa
# xv required for nvidia blob/amdgpu/mesa
# glamor required for xwayland support
-# b_lto set to false or build fails
# b_pgo set to off or build fails
# dpms and dri1 set to true or xf86-video-amdgpu build fails
+### xorg flag needs to be set to false for a successful build with -flto / b_lto enabled
+
# Print config
meson configure build
ninja $NINJAFLAGS -C build
@@ -241,19 +242,19 @@ package_xorg-server-rootless-nosystemd-minimal-git() {
# install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xorg-server/COPYING
#}
-package_xorg-server-xwayland-rootless-nosystemd-minimal-git() {
- pkgdesc="run X clients under wayland"
- depends=(libxfont2 libepoxy pixman xorg-server-common
- nettle)
- optdepends=('libunwind: unwind backtrace support')
- conflicts=('xorg-server-xwayland' 'xorg-xwayland')
- provides=('xorg-server-xwayland' 'xorg-xwayland')
+#package_xorg-server-xwayland-rootless-nosystemd-minimal-git() {
+# pkgdesc="run X clients under wayland"
+# depends=(libxfont2 libepoxy pixman xorg-server-common
+# nettle)
+# optdepends=('libunwind: unwind backtrace support')
+# conflicts=('xorg-server-xwayland' 'xorg-xwayland')
+# provides=('xorg-server-xwayland' 'xorg-xwayland')
- _install fakeinstall/usr/bin/Xwayland
+# _install fakeinstall/usr/bin/Xwayland
# license
# install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xorg-server/COPYING
-}
+#}
package_xorg-server-devel-rootless-nosystemd-minimal-git() {
pkgdesc="Development files for the X.Org X server"