summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJat2024-04-23 16:26:12 +0800
committerJat2024-04-23 16:26:12 +0800
commit6c9980bf69793ed274cd25172c070548a53781a3 (patch)
tree95103aa1c72c703c964385fbfb1dbf0165b4c8ef /PKGBUILD
parent75f25afa404124d07d229793f5e4c34064efc29f (diff)
downloadaur-6c9980bf69793ed274cd25172c070548a53781a3.tar.gz
Enhance build configuration with LTO CFLAGS and document Xorg test dependency
Signed-off-by: Jat <jat@sinosky.org>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bfd99b9e4954..95ae28e0e805 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,13 +30,18 @@ build() {
cd "$srcdir/$_pkgname"
./bootstrap
- ./configure --prefix="/usr" --enable-glamor
+
+ CFLAGS="$CFLAGS -ffat-lto-objects" \
+ ./configure --prefix=/usr \
+ --enable-glamor
+
make
}
check() {
cd "$srcdir/$_pkgname"
+ # https://github.com/neutrinolabs/xorgxrdp/pull/308
XORG=/usr/lib/Xorg make check
}