summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGaetan Bisson2019-03-27 11:27:15 -1000
committerGaetan Bisson2019-03-27 11:27:15 -1000
commitb0d5c7c43f6561f173a9914aa5f29d6be22f0568 (patch)
treebfa52454aea527060c09c673dc2ef7518da422d2 /PKGBUILD
downloadaur-xournal.tar.gz
initial commit of xournal
dropped from the official repos in favor of xournalpp
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df69a0a1b921
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=xournal
+pkgver=0.4.8.2016
+pkgrel=3
+pkgdesc='Notetaking and sketching application'
+url='http://xournal.sourceforge.net/'
+license=('GPL')
+arch=('x86_64')
+optdepends=('ghostscript: import PS/PDF files as bitmap backgrounds')
+depends=('libgnomecanvas' 'poppler-glib' 'shared-mime-info' 'desktop-file-utils' 'hicolor-icon-theme')
+source=("https://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('b25898dbd7a149507f37a16769202d69fbebd4a000d766923bbd32c5c7462826')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install desktop-install
+}