summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Freund2021-07-22 12:21:08 +0200
committerFlorian Freund2021-07-22 12:21:08 +0200
commit1e1a997b854c8d1455ada8a9be964292feceb899 (patch)
tree790f99548d6a501c2b1d541649c170200f913239 /PKGBUILD
parent862ea08ac50c7ae6cb0eccb796af0bb9075238b0 (diff)
downloadaur-1e1a997b854c8d1455ada8a9be964292feceb899.tar.gz
Remove config path override and fix version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53ff1e2520e9..98a7dd44df83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname="xournalpp"
pkgname="${_pkgname}-git"
-pkgver=1.0.15.r715.g8f83a043
+pkgver=nightly.r0.gb2453554
pkgrel=1
pkgdesc='Xournal++ is a handwriting Notetaking software with PDF annotation support. Supports Pen input like Wacom Tablets.'
arch=('i686' 'x86_64' 'aarch64')
@@ -14,7 +14,6 @@ license=('GPL2')
makedepends=('git' 'cmake' 'cppunit')
depends=('texlive-bin' 'gtk3' 'poppler-glib' 'libxml2' 'portaudio' 'libsndfile' 'lua' 'libzip')
conflicts=('xournalpp')
-install="xournalpp.install"
source=("${_pkgname}::git+https://github.com/xournalpp/xournalpp.git")
sha256sums=('SKIP')
@@ -28,14 +27,9 @@ prepare() {
}
build() {
- if [ -z "$XDG_CONFIG_HOME" ]; then
- configdir=".config"
- else
- configdir="$(realpath --relative-to="$HOME" "$XDG_CONFIG_HOME")"
- fi
cd "${srcdir}/${_pkgname}/build"
- cmake -DCMAKE_INSTALL_PREFIX="/usr/" -DDEV_CONFIG_DIR="$configdir/xournalpp" -DENABLE_CPPUNIT=ON ..
+ cmake -DCMAKE_INSTALL_PREFIX="/usr/" -DENABLE_CPPUNIT=ON ..
cmake --build . --target pot
cmake --build . --target translations
cmake --build .