summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Freund2019-07-23 18:37:18 +0200
committerFlorian Freund2019-07-23 18:37:18 +0200
commit8204c054d7ff001d1b793dd70633323ddf78c83e (patch)
tree378975324deda67f0b6ff18decf00060caec0b39 /PKGBUILD
parent0788e469debb7d5f5a154945c1171b627f0029d2 (diff)
downloadaur-8204c054d7ff001d1b793dd70633323ddf78c83e.tar.gz
Enable tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9cfe2749be71..f0b0b4d3870b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,9 @@ pkgdesc='Xournal++ is a handwriting Notetaking software with PDF annotation supp
arch=('i686' 'x86_64')
url="https://github.com/xournalpp/xournalpp"
license=('GPL2')
-makedepends=('git' 'cmake' 'gettext')
-depends=('texlive-bin' 'gtk3' 'glib2' 'poppler-glib' 'libxml2' 'portaudio' 'libsndfile' 'lua' 'libzip')
+makedepends=('git' 'cmake' 'cppunit')
+depends=('texlive-bin' 'gtk3' 'glib2' 'poppler-glib' 'libxml2' 'portaudio' 'libsndfile' 'libzip')
+optdepends=('lua>=5.3: Enable Xournal++ Plugins')
conflicts=('xournalpp')
install="xournalpp.install"
source=("${_pkgname}::git+https://github.com/xournalpp/xournalpp.git")
@@ -34,8 +35,15 @@ build() {
configdir="$(realpath --relative-to="$HOME" "$XDG_CONFIG_HOME")"
fi
cd "${srcdir}/${_pkgname}/build"
- cmake -DCMAKE_INSTALL_PREFIX="/usr/" -DDEV_CONFIG_DIR="$configdir/xournalpp" ..
- make
+
+ cmake -DCMAKE_INSTALL_PREFIX="/usr/" -DDEV_CONFIG_DIR="$configdir/xournalpp" -DENABLE_CPPUNIT=ON ..
+ cmake --build .
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}/build"
+
+ cmake --build . --target test
}
package() {