summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Freund2021-11-17 01:43:57 +0100
committerFlorian Freund2021-11-17 01:43:57 +0100
commitb5f30d201d0d140050a3e549a27ff761d87217b8 (patch)
tree0bf6cf74ebec39e297ad678199fc9c20d59215ce /PKGBUILD
parent7ee925ccae0bffaba61b804608c5e398b5b8ef6e (diff)
downloadaur-b5f30d201d0d140050a3e549a27ff761d87217b8.tar.gz
Move test suite from cppunit to gtest
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86f13f65e5e9..0b0acf9d7900 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
_pkgname="xournalpp"
pkgname="${_pkgname}-git"
-pkgver=1.1.0.r18.g97c20f62
+pkgver=1.1.0.r104.gc6ae5c7fc
pkgrel=1
pkgdesc='Xournal++ is a handwriting Notetaking software with PDF annotation support. Supports Pen input like Wacom Tablets.'
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/xournalpp/xournalpp"
license=('GPL2')
-makedepends=('git' 'cmake' 'cppunit')
-depends=('texlive-bin' 'gtk3' 'poppler-glib' 'libxml2' 'portaudio' 'libsndfile' 'lua' 'libzip')
+makedepends=('git' 'cmake' 'help2man')
+depends=('texlive-bin' 'gtk3' 'poppler-glib' 'libxml2' 'portaudio' 'libsndfile' 'lua53' 'lua53-lgi' 'libzip')
conflicts=('xournalpp')
source=("${_pkgname}::git+https://github.com/xournalpp/xournalpp.git")
sha256sums=('SKIP')
@@ -29,10 +29,11 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}/build"
- cmake -DCMAKE_INSTALL_PREFIX="/usr/" -DENABLE_CPPUNIT=ON ..
+ cmake -DCMAKE_INSTALL_PREFIX="/usr/" -DENABLE_GTEST=ON ..
cmake --build . --target pot
cmake --build . --target translations
cmake --build .
+ cmake --build . --target test-units
}
check() {
@@ -43,6 +44,5 @@ check() {
package() {
cd "${srcdir}/${_pkgname}/build"
-
- make DESTDIR="${pkgdir}/" install
+ DESTDIR="${pkgdir}/" cmake --build . --target install
}