summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornate2016-11-07 20:33:52 -0700
committernate2016-11-07 20:33:52 -0700
commit0f725ae9839a3c180df259080811d6e87db0eabf (patch)
tree65634da73dc8f22adf1b863d915cf5c2ebf01419 /PKGBUILD
parent6724cb600841c394261cafcdfd6a41752b9b098d (diff)
downloadaur-0f725ae9839a3c180df259080811d6e87db0eabf.tar.gz
1.2.0 bump; fix some deps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dcf34e7bd398..64e669c5c6c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Nate Simon <aurpkg (at natesimon.net)>
pkgname=xplayer
-pkgver=1.0.7
+pkgver=1.2.0
pkgrel=1
pkgdesc="Simple media player. X-Apps Project."
arch=('i686' 'x86_64')
license=('GPL')
depends=('clutter-gtk' 'clutter-gst' 'xplayer-plparser'
'desktop-file-utils' 'iso-codes' 'yelp-xsl'
- 'libpeas' 'gsettings-desktop-schemas'
- 'python2-gobject' 'gst-plugins-base' 'gst-plugins-good')
-makedepends=('gnome-common' 'gtk-doc' 'gobject-introspection')
+ 'libpeas' 'gsettings-desktop-schemas' 'dbus-glib'
+ 'python2-gobject' 'gst-plugins-base' 'gst-plugins-good'
+ 'xapps')
+makedepends=('gnome-common' 'gtk-doc' 'gobject-introspection' 'vala')
optdepends=('gst-libav: Extra media codec support')
provides=($_pkgname)
conflicts=('xplayer-git')
@@ -18,14 +19,13 @@ url='https://github.com/linuxmint/xplayer'
install=xplayer.install
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/linuxmint/${pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('6295bb19c2125a5439636809e61d9306')
+md5sums=('f6753f84c195075e7c37fbd87b366b74')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- sed -i 's/PYTHON=python/PYTHON=python2/g' py-compile
# https://github.com/linuxmint/xplayer/issues/22
- # I don't think there is a switch to disable grilo, so just bump the required
+ # No switch to disable grilo, so just bump the required
# version to something that obviously won't be satisfied.
sed -i 's/GRILO_REQS=0.2.0/GRILO_REQS=0.9.0/g' configure.ac