summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTomasz Żok2018-11-02 12:05:05 +0100
committerTomasz Żok2018-11-02 12:05:05 +0100
commit6b7f8dc29d550f28bf0d52fc54a1079f69b6ecf5 (patch)
tree7888426fef2796c53c1f0ef89eeeabc541c2e6da /PKGBUILD
parent654bb0525663fe378e61a788ceeff2a0ad29df3a (diff)
downloadaur-6b7f8dc29d550f28bf0d52fc54a1079f69b6ecf5.tar.gz
XPLOR-NIH 2.49
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e001c396b25..ac2640f9827a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Tomasz Zok <tomasz.zok [at] gmail.com>
pkgname=xplor-nih
-pkgver=2.48
+pkgver=2.49
pkgrel=1
pkgdesc="XPLOR-NIH is a structure determination program which builds on the X-PLOR program, including additional tools developed at the NIH"
arch=('x86_64')
url="https://nmr.cit.nih.gov/xplor-nih/"
license=('custom')
-depends=('ncurses5-compat-libs')
+depends=('ncurses5-compat-libs' 'libselinux')
source=('LICENSE'
"${pkgname}.md5")
md5sums=('SKIP'
@@ -32,18 +32,22 @@ prepare() {
build() {
cd "${pkgname}-${pkgver}"
- ./configure -symlinks symlinks/
+ ./configure
# revert change from prepare()
sed -i "s|^XPLOR_DIR=.*$|XPLOR_DIR=/opt/${pkgname}-${pkgver}|" "bin/xplor"
}
package() {
- install -D -t "${pkgdir}/usr/bin/" ${pkgname}-${pkgver}/symlinks/*
- find ${pkgname}-${pkgver}/symlinks/ -delete
+ install -d "${pkgdir}/usr/bin"
+ eval $(cat "${pkgname}-${pkgver}/configure" | awk '/scriptFiles=/,/"$/ { gsub(/\\/, ""); print }')
+ for script in getBest findXcookie $scriptFiles; do
+ ln -s "/opt/${pkgname}-${pkgver}/bin/$script" "${pkgdir}/usr/bin/"
+ done
install -d "${pkgdir}/opt/"
- cp -R "${pkgname}-${pkgver}" "${pkgdir}/opt/"
+ cp --recursive "${pkgname}-${pkgver}" "${pkgdir}/opt/"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ cp LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
}