summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbug2017-03-17 12:41:49 +0200
committerbug2017-03-17 12:41:49 +0200
commit3834f9829242bf44c0c908ca267077805137826d (patch)
tree5da9bade5f9ce8a4775597cc58fb576f55029dfa /PKGBUILD
parentf5b838e47649f71058ab44aa45f86e8bbcd78132 (diff)
downloadaur-3834f9829242bf44c0c908ca267077805137826d.tar.gz
Update to 2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8bda09bddabd..6127efafdfc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,25 @@
# Contributor: Bug <bug2000@gmail.com>
# Maintainer: Bug <bug2000@gmail.com>
pkgname=xpra-winswitch
-pkgver=1.0.4
+pkgver=2.0
pkgrel=1
pkgdesc="Modified version of xpra by Winswitch"
arch=('i686' 'x86_64')
url='http://xpra.org/'
license=('GPL2')
depends=('python2' 'pygtk' 'libxtst' 'python2-pillow' 'python2-lz4'
- 'ffmpeg' 'libvpx' 'xf86-video-dummy' 'libwebp' 'libxkbfile'
+ 'ffmpeg' 'libvpx' 'xf86-video-dummy' 'libxkbfile'
'python2-numpy' 'rencode' 'python2-opengl'
- 'python2-gtkglext' 'python-lz4' 'python-opengl' 'python2-opengl')
+ 'python2-gtkglext' 'python-lz4' 'python-opengl')
optdepends=('x264: Codec' 'python2-dbus: dbus features'
'python2-pycups: Printing support' 'python2-netifaces: mdns'
'python2-cryptography: Cryptography'
- 'python-cryptography: Cryptography'
- 'python2-crypto: Cryptography'
- 'python-crypto: Cryptography')
+ 'python-cryptography: Cryptography')
conflicts=('parti-all')
provides=('parti-all')
makedepends=('python2-setuptools' 'cython2')
backup=('etc/xpra/xpra.conf' 'etc/xpra/xorg.conf'
- 'etc/xpra/cuda.conf' 'etc/xpra/nvenc.keys'
+# 'etc/xpra/cuda.conf' 'etc/xpra/nvenc.keys'
'etc/xpra/conf.d/05_features.conf'
'etc/xpra/conf.d/10_network.conf'
'etc/xpra/conf.d/12_ssl.conf'
@@ -37,7 +35,7 @@ backup=('etc/xpra/xpra.conf' 'etc/xpra/xorg.conf'
'etc/xpra/conf.d/60_server.conf'
'etc/xpra/conf.d/65_proxy.conf')
source=("https://xpra.org/src/xpra-$pkgver.tar.xz")
-sha256sums=('c841940957761e60454eac44c955d174b3d864c853f28b387e784a6d85fc9924')
+sha256sums=('ca9e9622a9d435f9591bf60baec50ea02ebad4e0c0017e1df43dfddd6616e807')
build() {
cd ${srcdir}/xpra-$pkgver