summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-02-22 08:52:54 +0800
committerzxp198210052024-02-22 08:52:54 +0800
commit8677ef4eecdf642d9503fb10437105c5deff040b (patch)
tree3904d28473e4f08fd05b87deb07d44e5a4257ad8 /PKGBUILD
parentf41ef6153fb60b056dd279864ced5befcf90b9c5 (diff)
downloadaur-8677ef4eecdf642d9503fb10437105c5deff040b.tar.gz
fix errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c3e176b09ec..944002554b82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,15 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=xraygui-bin
pkgver=1.8
-pkgrel=2
+pkgrel=3
pkgdesc="A small and nimble GUI for XRay"
arch=('x86_64')
url="https://github.com/AKotov-dev/XRayGUI"
-license=("GPL3")
+license=("GPL-3.0-only")
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
'gtk2'
- 'fping'
- 'cairo'
- 'at-spi2-core'
- 'libx11'
- 'pango'
- 'gdk-pixbuf2'
'p7zip'
'wget'
'zenity'
@@ -29,12 +23,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('5790a63bad60a2722409dfb4165f5db0dade46555e0ca6c0d4553d556bf9aa14'
- '810844dac159a0c6d46da58e10d57f1b4c958749efa8c6776515240823076074')
+ 'a309fe22af7140f6be0fd1475247a44a974503bdf5428aedce123ed100cb2350')
build() {
sed -e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|${pkgname%-bin}|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.xz"
+ bsdtar -xf "${srcdir}/data."*
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" -t "${pkgdir}/usr/bin/${pkgname%-bin}"