summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2015-05-26 10:30:42 -0600
committerBrian Bidulock2015-06-10 23:49:48 -0600
commitf6ec4cc38396e75cbc5ed3d1f8173ab57958c3b7 (patch)
treeabf6a064319b986d88114fc87b3a277b954908d6 /PKGBUILD
parent60719abbd0ca2e93a1db0e5cc51728418c7805a6 (diff)
downloadaur-f6ec4cc38396e75cbc5ed3d1f8173ab57958c3b7.tar.gz
version 0.6.1-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c49d5fa89826..6033e34d3456 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
-# Maintainer: Tomasz Zok <tomasz.zok [at] gmail.com>
-# Maintainer: techryda <techryda at silentdome dot com>
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Tomasz Zok <tomasz.zok [at] gmail.com>
+# Contributor: techryda <techryda at silentdome dot com>
# Contributor: Mathias R. <pu154r@overlinux.org>
pkgname=xrdp
pkgver=0.6.1
-pkgrel=1
+pkgrel=2
pkgdesc="An open source remote desktop protocol (RDP) server"
url="http://xrdp.sourceforge.net/"
arch=('i686' 'x86_64' 'armv6h')
license=('GPL')
depends=('tigervnc')
-source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-v$pkgver.tar.gz"
+source=(https://github.com/neutrinolabs/${pkgname}/archive/v${pkgver}.tar.gz
'xrdp.service'
'xrdp-sesman.service')
md5sums=('26099c6588943262023607c1b4e774d8'
@@ -17,23 +18,26 @@ md5sums=('26099c6588943262023607c1b4e774d8'
'58eb44bdc7ca5bb436d6fd66826f9b0f')
prepare() {
- cd "${pkgname}-v${pkgver}"
+ cd "${pkgname}-${pkgver}"
# Fix path in xrdp.sh file
sed -i 's|/usr/local/sbin|/usr/bin|' instfiles/xrdp.sh
}
build() {
- cd "${pkgname}-v${pkgver}"
+ cd "${pkgname}-${pkgver}"
./bootstrap
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --sbindir=/usr/bin
make
}
package() {
- cd "${pkgname}-v${pkgver}"
+ cd "${pkgname}-${pkgver}"
make DESTDIR="$pkgdir" install
cd ${pkgdir}
# Install systemd service files
mkdir -p usr/lib/systemd/system
cp ${srcdir}/*.service usr/lib/systemd/system
}
+md5sums=('ada45a1e8ca0be779b6ef0eda782aa13'
+ '0cb760b3e8a34f9bdf4daa871444d74c'
+ '58eb44bdc7ca5bb436d6fd66826f9b0f')