summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortaotieren2024-08-24 20:12:17 +0800
committertaotieren2024-08-24 20:12:17 +0800
commit73b43e3ec31dd0ac51b49d068b48d526b3508cac (patch)
tree44994b66e8877aa2a07bad2ca0e7cc2ed31e4b46 /PKGBUILD
parent5217fdc122a9fdaad3e8c11286fba0331ffbc684 (diff)
downloadaur-73b43e3ec31dd0ac51b49d068b48d526b3508cac.tar.gz
[lilac] updated to 1.0.5.r3.gb263009-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index becd1167740d..cc57b87e9762 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,13 @@
# Maintainer: taotieren <admin@taotieren.com>
pkgname=xrock-git
-pkgver=1.0.4.r13.g1a9e5ca
+pkgver=1.0.5.r3.gb263009
pkgrel=1
epoch=
pkgdesc="The low level tools for rockchip SOC with maskrom and loader mode support."
-arch=('x86_64')
+arch=(x86_64
+ aarch64
+ riscv64)
url="https://github.com/xboot/xrock"
license=('MIT')
depends=('libusb')
@@ -21,6 +23,11 @@ pkgver() {
git describe --long --tags | sed 's/^v//g' | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare()
+{
+ git -C "${srcdir}/${pkgname%-git}" clean -dfx
+}
+
build() {
cd "${srcdir}/${pkgname%-git}"
make