summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Gizdov2017-05-30 15:28:04 +0200
committerKonstantin Gizdov2017-05-30 15:28:04 +0200
commit9ae61b2f3ee03696d5f787f75b61b67f2c09b1af (patch)
tree42faff1f73c6ee581a06630944255b795a259f15 /PKGBUILD
parentdbb9b88a0b66775f34786a658a88640ad7bda874 (diff)
downloadaur-9ae61b2f3ee03696d5f787f75b61b67f2c09b1af.tar.gz
update to v4.6.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3cfd22dcbc8..1579bbea0ce8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Konstantin Gizdov < arch at kge dot pw >
# Contributor: Jan Kašpar < jan.kaspar at gmail dot com >
pkgname=xrootd
-pkgver=4.6.0
-pkgrel=3
+pkgver=4.6.1
+pkgrel=1
pkgdesc="Software framework for fast, low latency, scalable and fault tolerant data access."
provides=('xrootd' 'xrootd-abi0')
arch=('i686' 'x86_64')
url="http://xrootd.org/"
license=('LGPL3')
-depends=('ceph' 'libxml2' 'openssl-1.0')
+depends=('ceph' 'libxml2')
makedepends=('cmake')
options=('!emptydirs')
source=("http://xrootd.org/download/v${pkgver}/xrootd-${pkgver}.tar.gz"
'gcc7.patch')
-sha256sums=('b50f7c64ed2a4aead987de3fdf6fce7ee082407ba9297b6851cd917db72edd1d'
+sha256sums=('0261ce760e8788f85d68918d7702ae30ec677a8f331dae14adc979b4cc7badf5'
'20f4d966f302e44e4729df6454f4e12570522632a25726e38523f7fbb4b01941')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -26,8 +26,6 @@ build() {
msg2 'Configuring...'
cmake "${srcdir}/${pkgname}-${pkgver}" \
-DCMAKE_BUILD_TYPE:STRING=Release \
- -DOPENSSL_ROOT_DIR=/usr/lib/openssl-1.0 \
- -DOPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0 \
-DCMAKE_INSTALL_LIBDIR:PATH=lib \
-DCMAKE_INSTALL_PREFIX:PATH=/usr