summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Radke2010-06-09 17:43:57 +0000
committerAndreas Radke2010-06-09 17:43:57 +0000
commit4ca02e4cb4ab05884f0889f371f9e0aebe16add4 (patch)
tree91898e39f06a4d8dbee58ddc054b37c59405cb3a /PKGBUILD
parent935d0ef4011a6283234c9309b572916db83be8af (diff)
downloadaur-4ca02e4cb4ab05884f0889f371f9e0aebe16add4.tar.gz
split out gimp plugin; add patch to fix the help browser
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 48 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b45c75d6f8f..d0d267c14147 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,65 @@
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Sarah Hay <sarahhay@mb.sympatico.ca>
-pkgname=xsane
+pkgbase=xsane
+pkgname=('xsane' 'xsane-gimp')
pkgver=0.997
-pkgrel=2
-pkgdesc="A GTK-based X11 frontend for SANE and plugin for Gimp."
+pkgrel=3
arch=(i686 x86_64)
url="http://www.xsane.org"
license=('GPL2')
-makedepends=('gimp')
-depends=('gtk2' 'lcms' 'sane' 'zlib' 'libjpeg')
-install=$pkgname.install
-source=(http://www.xsane.org/download/$pkgname-$pkgver.tar.gz)
+makedepends=('gtk2' 'lcms' 'sane' 'zlib' 'libjpeg' 'gimp')
+source=(http://www.xsane.org/download/$pkgname-$pkgver.tar.gz
+ xsane-0.995-xdg-open.patch)
+md5sums=('8377b3e3b792f3d2b7f13895467c7082'
+ '15541ff0ddc10acfa2059cf99d5478eb')
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --mandir=/usr/share/man --disable-gimp
+ # fix use "xdg-open" instead of "netscape" to launch help browser - taken from Fedora
+ patch -Np1 -i ${srcdir}/xsane-0.995-xdg-open.patch || return 1
+
+ ./configure --prefix=/usr --mandir=/usr/share/man --enable-gimp
/usr/bin/make || return 1
- /usr/bin/make DESTDIR="$pkgdir" install || return 1
- # build xsane with gimp
+ mv src/xsane src/xsane-gimp
+
+ # build again with gimp enabled
make clean
- ./configure --prefix=/usr
- /usr/bin/make || return 1
- install -D -m755 "$srcdir/$pkgname-$pkgver/src/xsane" "$pkgdir/usr/bin/xsane-gimp" || return 1
+ ./configure --prefix=/usr --mandir=/usr/share/man --disable-gimp
+}
+
+package_xsane() {
+ pkgdesc="A GTK-based X11 frontend for SANE and plugin for Gimp."
+ install=$pkgname.install
+ depends=('gtk2' 'lcms' 'sane' 'zlib' 'libjpeg')
+ optdepends=('xsane-gimp; for gimp plugin support')
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+package_xsane-gimp() {
+ pkgdesc="XSane Gimp plugin"
+ depends=('sane' 'gimp')
+ cd "$srcdir/$pkgname-$pkgver"
+ install -D -m755 src/xsane-gimp ${pkgdir}/usr/bin/xsane-gimp || return 1
+
## For making Gimp Plugin available
/bin/mkdir -p "$pkgdir/usr/lib/gimp/2.0/plug-ins"
cd "$pkgdir/usr/lib/gimp/2.0/plug-ins/"
/bin/ln -s ../../../../bin/xsane-gimp xsane
+
+# http://cvs.fedoraproject.org/viewvc/rpms/xsane/devel/xsane.spec?revision=1.80&view=markup
+# when makepkg will allow splitted pkg install file support we might change add a xsane-gimp.install file with the commands that are used by fedora,
+# gentoo has something similar
+#%post gimp
+#107 if [ -x "%{_sbindir}/gimp-plugin-mgr" ]; then
+#108 %{_sbindir}/gimp-plugin-mgr --install xsane
+#109 fi
+#110
+#111 %preun gimp
+#112 if [ $1 = 0 ]; then
+#113 if [ -x "%{_sbindir}/gimp-plugin-mgr" ]; then
+#114 %{_sbindir}/gimp-plugin-mgr --uninstall xsane
+#115 fi
+#116 fi
}
-md5sums=('8377b3e3b792f3d2b7f13895467c7082')