summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlad Wenter2015-08-18 23:06:42 +0200
committerAlad Wenter2015-08-18 23:06:42 +0200
commitfeb3f0ce86e5490c1e167ff9308e44992e1309de (patch)
treeaf230e251d75208d6288b83dba897aa28b46db4d /PKGBUILD
parent36a9b2d916f66840191c963b730f4bd72f7628a6 (diff)
downloadaur-feb3f0ce86e5490c1e167ff9308e44992e1309de.tar.gz
fix pkgver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46862fc0bc92..ad8d5e168496 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
# Maintainer: Alad Wenter <https://wiki.archlinux.org/index.php/Special:EmailUser/Alad>
# Contributor: Raymond Wagenmaker <raymondwagenmaker@gmail.com>
pkgname=xss-lock-git
-pkgver=v0.3.0.4.g1e158fb
+pkgver=0.3.0.r4.g1e158fb
pkgrel=1
+
pkgdesc="Use external locker as X screen saver"
arch=(i686 x86_64)
url="https://bitbucket.org/raymonad/xss-lock"
license=('MIT')
+
depends=('xcb-util' 'systemd')
makedepends=('cmake' 'python-docutils' 'git')
optdepends=('bash-completion: for bash completion')
-source=("$pkgname::git+https://bitbucket.org/raymonad/${pkgname%-git}.git")
-md5sums=('SKIP')
provides=('xss-lock')
conflicts=('xss-lock')
+source=("$pkgname::git+https://bitbucket.org/raymonad/${pkgname%-git}.git")
+md5sums=('SKIP')
+
pkgver() {
cd "$pkgname"
- local ver="$(git describe --long)"
- printf "%s" "${ver//-/.}"
+ git describe | sed 's/^v//; s/-/.r/; s/-/./'
}
build() {
@@ -30,7 +32,7 @@ build() {
package() {
cd "$pkgname"
make DESTDIR="$pkgdir" install
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
}
# vim:set ts=2 sw=2 et: