summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlad Wenter2015-08-03 08:49:52 +0200
committerAlad Wenter2015-08-03 08:49:52 +0200
commitb7b1e94114a9d3f63586d9a3a20a67a831c5b261 (patch)
tree105dfd77a8cd3575d5b8dc6b40a4cf449a37b7a3 /PKGBUILD
parent0f68f59defbf0a683f775e1311007082e71e65e0 (diff)
downloadaur-b7b1e94114a9d3f63586d9a3a20a67a831c5b261.tar.gz
Ignore X screensaver (fixes #5)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc0ddfcda3ad..4eecc6e7f24a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,12 @@ license=('MIT')
depends=('xcb-util' 'systemd')
makedepends=('cmake' 'python-docutils' 'git')
optdepends=('bash-completion: for bash completion')
-source=("$pkgname::git+https://bitbucket.org/raymonad/${pkgname%-git}.git")
+source=("$pkgname::git+https://bitbucket.org/raymonad/${pkgname%-git}.git"
+ 'ignore-blank.patch')
+md5sums=('SKIP'
+ 'b12e5dd8463d6300ebe3a2b525a12926')
provides=('xss-lock')
conflicts=('xss-lock')
-md5sums=('SKIP')
pkgver() {
cd "$pkgname"
@@ -21,6 +23,11 @@ pkgver() {
printf "%s" "${ver//-/.}"
}
+prepare() {
+ cd "$pkgname"/src
+ patch -p0 < "$srcdir"/ignore-blank.patch
+}
+
build() {
cd "$pkgname"
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release