summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Orefice2016-11-03 14:17:38 +0100
committerAntonio Orefice2016-11-03 14:17:38 +0100
commitbea0408dc6f8278660de8acdba1784ea7b31997e (patch)
treed25e885ee395121ab7b66e07400195461054679d /PKGBUILD
parenta8ede216b31e97ca22628d9df986bf7eb3b7e185 (diff)
downloadaur-bea0408dc6f8278660de8acdba1784ea7b31997e.tar.gz
0.21.384
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD59
1 files changed, 28 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 722ca6707464..0a58911ade6f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer : Antonio Orefice <xt7player@gmail.com>
pkgname=xt7-player-mpv
-pkgver=0.20.384
+pkgver=0.21.384
#hotfix=-hotfix
pkgrel=1
_realname=xt7-player-mpv
@@ -10,32 +10,30 @@ arch=('any')
url="http://xt7-player.sourceforge.net/xt7forum/"
license=('custom')
-depends=('gambas3-gb-image>=3.6.2'
- 'gambas3-runtime>=3.9.0'
- 'gambas3-gb-form>=3.9.0'
- 'gambas3-gb-qt4>=3.9.0'
- 'gambas3-gb-form>=3.9.0'
- 'gambas3-gb-dbus>=3.9.0'
- 'gambas3-gb-desktop>=3.9.0'
- 'gambas3-gb-settings>=3.9.0'
- 'gambas3-gb-form-mdi>=3.9.0'
- 'gambas3-gb-form-dialog>=3.9.0'
- 'gambas3-gb-net>=3.9.0'
- 'gambas3-gb-net-curl>=3.9.0'
- 'gambas3-gb-qt4-ext>=3.9.0'
- 'gambas3-gb-web>=3.9.0'
- 'gambas3-gb-util-web>=3.9.0'
- 'gambas3-gb-libxml>=3.9.0'
- 'gambas3-gb-form-stock>=3.9.0'
- 'gambas3-gb-image>=3.9.0'
- 'gambas3-gb-compress>=3.9.0'
- 'gambas3-gb-signal>=3.9.0'
- 'gambas3-gb-desktop-x11>=3.9.0'
- 'gambas3-gb-args>=3.9.0'
- 'mpv>=1:0.20.0'
- 'taglib'
- 'youtube-dl>=2015.08.28'
- 'wget')
+depends=(
+ 'gambas3-gb-args'
+ 'gambas3-gb-compress'
+ 'gambas3-gb-dbus'
+ 'gambas3-gb-desktop'
+ 'gambas3-gb-desktop-x11'
+ 'gambas3-gb-form'
+ 'gambas3-gb-form-dialog'
+ 'gambas3-gb-form-mdi'
+ 'gambas3-gb-form-stock'
+ 'gambas3-gb-image'
+ 'gambas3-gb-libxml'
+ 'gambas3-gb-net'
+ 'gambas3-gb-net-curl'
+ 'gambas3-gb-qt5'
+ 'gambas3-gb-settings'
+ 'gambas3-gb-signal'
+ 'gambas3-gb-util-web'
+ 'gambas3-gb-web'
+ 'mpv>=1:0.21.0'
+ 'taglib'
+ 'youtube-dl>=2015.08.28'
+ 'wget'
+)
makedepends=('gambas3-devel')
optdepends=('python2: for Opensubtitles.org integration' 'ladspa: more audio plugins' 'linuxtv-dvb-apps: for DVB support' 'dvbsnoop: DVBT EPG' 'xdg-utils: for desktop integration' 'xbindkeys: for global hotkeys support' 'aria2: for youtube segmented downloads')
@@ -43,9 +41,8 @@ optdepends=('python2: for Opensubtitles.org integration' 'ladspa: more audio plu
source=(https://github.com/kokoko3k/xt7-player-mpv/archive/$pkgver$hotfix.tar.gz 'license.txt')
-
build() {
- cd ${srcdir}/${_realname}-${pkgver}$hotfix
+ cd ${srcdir}/${_realname}-v${pkgver}$hotfix
gbc3 -e -a -g -t -p -m
gba3 || return 1
@@ -54,7 +51,7 @@ build() {
package() {
cd ${srcdir}/${_realname}-${pkgver}$hotfix/
-
+
sed -i 's/Exec=xt7-player-mpv.gambas/Exec=xt7-player-mpv/' ./xt7-player-mpv.desktop
install -d ${pkgdir}/usr/bin
@@ -65,5 +62,5 @@ package() {
}
-md5sums=('de6d630e3265ccf9a575ea6d51b0ad6b'
+md5sums=('5ba7458e9331bcd0fba7548c160e0094'
'b6f1380e33b47d0ed95c7ba1b3f4ec73')