summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid P2018-09-16 13:10:03 -0300
committerDavid P2018-09-16 13:10:03 -0300
commitdfdb5c52f480148f53734cb9e0e3834a81398ae4 (patch)
tree1edec90c4f62a0bae82cd055fc89ae51e4498579 /PKGBUILD
parent8fdb83f8208cd925b2e4f59f37a372c6d0d2ed0a (diff)
downloadaur-dfdb5c52f480148f53734cb9e0e3834a81398ae4.tar.gz
upgpkg: xtensa-elf-binutils 2.31.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ccb8aae16dd..d3171c4645f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,16 +6,16 @@
_target=xtensa-elf
pkgname=$_target-binutils
-pkgver=2.30
+pkgver=2.31.1
pkgrel=1
-pkgdesc="A set of programs to assemble and manipulate binary and object files for the Xtensa target"
+pkgdesc='A set of programs to assemble and manipulate binary and object files for the Xtensa target'
arch=('x86_64' 'i686' 'armv7h')
url="https://www.gnu.org/software/binutils/"
license=('GPL')
depends=('zlib')
source=("https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2"{,.sig}
'https://github.com/qca/open-ath9k-htc-firmware/raw/master/local/patches/binutils.patch')
-sha512sums=('c3ce91aa20f058ec589bf18c722bf651331b394db6378900cc813cc0eea3a331a96584d5ae090630b627369510397dccc9edfcd43d4aeefc99579f277a05c72c'
+sha512sums=('b42954e6f49a0adcd2676bdd77dfb59bfc25cec8184b007521d1e2b1d5d0593b58639e3d9448d5a40fe024c3cea386a37743627d6bb16d502f52a4a32b9573bd'
'SKIP'
'e10ed358794d7aa32ac25087afd804dc4c3028c4664d7608eb86147f041561d16209afa6501bc8a19e02386674011d567640175f6b8bf89275c243dc3b3a9980')
validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93' # Tristan Gingold <gingold@adacore.com>
@@ -55,7 +55,7 @@ check() {
# unset LDFLAGS as testsuite makes assumptions about which ones are active
# do not abort on errors - manually check log files
- make -k LDFLAGS="" check || true
+ make LDFLAGS="" -k check || true
}
package() {
@@ -64,7 +64,7 @@ package() {
make DESTDIR="$pkgdir" install
# Remove file conflicting with host binutils and manpages for MS Windows tools
- rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,nlmconv,windres,windmc}*
+ rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,windres,windmc}*
# Remove info documents that conflict with host version
rm -r "$pkgdir"/usr/share/info