summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornate2016-05-04 20:14:03 -0700
committernate2016-05-04 20:14:03 -0700
commitacbcda372779d37de26d613d1224e4036f074fc6 (patch)
treeca4c9f167ffb8a489c3b5c72206e31bf3279fca3 /PKGBUILD
downloadaur-acbcda372779d37de26d613d1224e4036f074fc6.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5938b6d9ed29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Nate Simon <aurpkg (at natesimon.net)>
+
+pkgname=xviewer-plugins-git
+pkgver=1.0.2.r2.g546f53e
+pkgrel=1
+pkgdesc="Plugins for xviewer. X-Apps Project (git version)."
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('xviewer-git' 'libpeas')
+makedepends=('gnome-common')
+provides=($_pkgname)
+conflicts=('xviewer-plugins-git')
+url='https://github.com/linuxmint/xviewer-plugins'
+
+source=('xviewer-plugins-git::git+https://github.com/linuxmint/xviewer-plugins.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${pkgname}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ${srcdir}/${pkgname}
+ ./autogen.sh --prefix="/usr" \
+ --localstatedir="/var" \
+ --libexecdir="/usr/lib/xviewer-plugins"
+ make
+}
+
+package(){
+ cd ${srcdir}/${pkgname}
+ make DESTDIR="$pkgdir/" install
+}
+