summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKarol Babioch2018-08-06 22:51:44 +0200
committerKarol Babioch2018-08-06 22:51:44 +0200
commitb84c4014fc15f24714f487a6df29f99cf3ad26e5 (patch)
tree83b6e13b47df6f91001d8a780688779d8ae51e77 /PKGBUILD
downloadaur-b84c4014fc15f24714f487a6df29f99cf3ad26e5.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ba48f8b5cef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Karol Babioch <karol@babioch.de
+
+pkgname=xwmfs-git
+pkgver=0.82.r0.gdf2b3c5
+pkgrel=1
+pkgdesc="X11 Window-Manager file system based on FUSE"
+arch=('x86_64')
+url="https://github.com/gerstner-hub/xwmfs"
+license=('GPL2')
+depends=('fuse')
+source=("git+https://github.com/gerstner-hub/xwmfs.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/xwmfs"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/xwmfs"
+ ./bootstrap
+ ./configure --prefix=/usr
+}
+
+package() {
+ cd "${srcdir}/xwmfs"
+ make DESTDIR="${pkgdir}" install
+}
+