summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Wojdyla2024-05-11 16:03:39 +0200
committerMichal Wojdyla2024-05-11 16:03:39 +0200
commit3b7411b0bbc1d17eb2b50f904aaa225312dace5f (patch)
treec7b53f2b450ac51f0596a2170e3e614d3af5bf6c /PKGBUILD
parent5c83e8599c1262b3d922f1492de0f5c1d10ecaad (diff)
downloadaur-3b7411b0bbc1d17eb2b50f904aaa225312dace5f.tar.gz
fix build with gcc14
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c60f5c593009..b7397865392f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,20 @@
pkgname=xyzsh
pkgver=1.5.8
-pkgrel=3
+pkgrel=4
pkgdesc="Interactive shell and text processing tools"
arch=('i686' 'x86_64')
url="https://github.com/ab25cq/xyzsh"
license=('MIT')
depends=('glibc' 'ncurses' 'oniguruma')
-source=(http://osdn.net/projects/${pkgname}/downloads/60140/${pkgname}-${pkgver}.tgz)
-md5sums=('4fab43dbd794fb4af871ac6c9989526b')
+source=(http://osdn.net/projects/${pkgname}/downloads/60140/${pkgname}-${pkgver}.tgz gcc14.patch)
+md5sums=('4fab43dbd794fb4af871ac6c9989526b'
+ '084be8ed51601d02c72218d8f9034927')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
-
+ # https://github.com/ab25cq/xyzsh/issues/5
+ patch -p1 -i ../gcc14.patch
./configure --prefix=/usr --sysconfdir=/etc --with-optimize
make -j1
}