summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobbert van der Helm2021-02-15 12:19:10 +0100
committerRobbert van der Helm2021-02-15 12:19:10 +0100
commit5d19f7578aafbf49351aff4acdc4bc8f0f76798b (patch)
treef0ceb6da66ea31e437b2a63459d4f68dcd114a1c /PKGBUILD
parente8ffd3f97a6f73cfc919746a0bcf91971ac95ae1 (diff)
downloadaur-5d19f7578aafbf49351aff4acdc4bc8f0f76798b.tar.gz
Work around compile errors with Wine 6.2
This commit is the exact same as regular yabridge 3.0.0, but with a small workaround for a regression introduced in Wine 6.2.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 14 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 191e1c12fc0b..90e75ca8bdcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
pkgname=yabridge
pkgver=3.0.0
-pkgrel=2
+_tmp_commit=c29bc59059b5d5000ce1f660a42bdb624b5925c9
+pkgrel=3
pkgdesc="A modern and transparent way to use Windows VST2 and VST3 plugins on Linux"
arch=('x86_64')
url="https://github.com/robbert-vdh/yabridge"
@@ -12,28 +13,17 @@ optdepends=('yabridgectl: utility for setting up and managing yabridge')
makedepends=('meson' 'ninja')
options=('!strip')
install=yabridge.install
-source=("https://github.com/robbert-vdh/yabridge/archive/$pkgver.tar.gz")
-sha256sums=('693bc7b2650bc6fc59fa95a724b2cc41e2b26e94614a2d3b0ce53454e411f58d')
+# TODO: Revert on the next release, this commit is exactly the same as 3.0.0
+# with a workaround for a regression in Wine 6.2 that would cause compile
+# errors
+# source=("https://github.com/robbert-vdh/yabridge/archive/$pkgver.tar.gz")
+source=("https://github.com/robbert-vdh/yabridge/archive/$_tmp_commit.tar.gz")
+sha256sums=('4a8b6a7931e8d71e0d9ad0d8a1f85c1a20e04bdc7569cff4c8ab2b760247b850')
build() {
- cd "$pkgname-$pkgver"
-
- # TODO: Once this has been fixed upstream, we can remove the warning again
- wine_version=$(wine --version | grep --only-matching -E '[0-9]+\.[0-9.]+' | head -n1)
- if [[ $wine_version == 6.2* ]]; then
- echo "#"
- echo "# WARNING: Wine 6.2 has a regression that will cause build errors when"
- echo "# compiling yabridge because the headers are no longer valid in"
- echo "# C++. The build will likely fail. Either temporarily downgrade"
- echo "# to a Wine 6.1 version or use the 'yabridge-bin' AUR package"
- echo "# instead until this is fixed."
- echo "#"
- echo "# Continuing in five seconds..."
- echo "#"
-
- # Or else the message will be very easy to miss
- sleep 5
- fi
+ # TODO: Revert
+ # cd "$pkgname-$pkgver"
+ cd "$pkgname-$_tmp_commit"
# Meson won't apply any new options or update wraps if they already exist, so
# if we're building from a dirty src/ directory we'll just nuke any cached
@@ -76,7 +66,9 @@ build() {
}
package() {
- cd "$pkgname-$pkgver/build"
+ # TODO: Revert
+ # cd "$pkgname-$pkgver/build"
+ cd "$pkgname-$_tmp_commit/build"
install -dm755 "${pkgdir}"/usr/bin
install yabridge-{host,group}.exe{,.so} "${pkgdir}"/usr/bin