summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorApplebloom2016-04-05 06:15:57 +0200
committerApplebloom2016-04-05 06:15:57 +0200
commit05c265e0685736291fbfb4d5990d1d91f0e2e06a (patch)
tree8d958350545c72655f8b34173c087f137af3d958 /PKGBUILD
downloadaur-05c265e0685736291fbfb4d5990d1d91f0e2e06a.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1d9f17f606f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: AppleBloom <rat.o.drat@gmail.com>
+
+pkgname='yafaray-experimental'
+pkgver='2.1.1'
+pkgrel='1'
+pkgdesc='A free open-source montecarlo raytracing engine.'
+arch=('i686' 'x86_64')
+url='http://yafaray.org/'
+license=('LGPL2.1')
+depends=('libxml2' 'libjpeg' 'libpng' 'libtiff' 'openexr' 'freetype2' 'zlib')
+makedepends=('cmake' 'swig' 'python')
+optdepends=('python: Python bindings')
+provides=('yafaray')
+conflicts=('yafaray' 'yafaray-git')
+source=('https://github.com/DavidBluecame/Core/archive/v2.1.1.tar.gz')
+md5sums=('1d0541629c48944e8a397d4ea4d2ccee')
+
+_srcdir="Core-$pkgver"
+
+build() {
+ cd "$_srcdir"
+
+ [[ -d build ]] && rm -rf build
+ mkdir build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DYAF_PY_VERSION=3.5 \
+ -DYAF_BINDINGS_PY_DIR=/usr/lib/python3.5 ..
+ make
+}
+
+package() {
+ cd "$_srcdir/build"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: